Legacy I/0O Configuration for E1 and E2 Brain Boards

Introduction

IMPORTANT: Configuration of E1 and E2 brain boards used with Opto 22 SNAP PAC
controllers, Modbus/TCP applications, and custom OptoMMP applications was simplified
in E1/E2 firmware R1.2a, PAC Project R9.5000, and PAC firmware R9.5a. If you have these
firmware and software versions, you don’t need to use this technical note. Instead, follow
steps in the PAC Control or PAC Manager user’s guide to configure E1s and E2s just like any
other Opto 22 I/O unit:

«  Opto 22 form 1710, PAC Control User’s Guide, Legacy Edition
«  Opto 22 form 1714, PAC Manager's User’s Guide, Legacy Edition

For Optomux Users

This technical note does not apply to E1 or E2 brain boards used in an Optomux /0O
system (on either a serial or Ethernet network). Configuration for Optomux operation
is done using jumpers on the brain board and in the Optomux application itself.

See the £1 and E2 User’s Guide (Opto 22 form 1563) and the Optomux Protocol Guide
(Opto 22 form 1572) for instructions and more information.

For E1/E2 firmware R1.1f and Lower

If you are not using minimum E1/E2 firmware R1.2a (and PAC Project R9.5000 and
PAC firmware R9.53, if appropriate) you will use the older configuration method in
this technical note. You may also want to use the older method if you are
reconfiguring an existing unit or want to match units already configured.

The combination of a brain board with a compatible 1/0 rack and modules is called
an /0 unit. This technical note describes how to configure E1 and E2 1/O units for an
/0 system that uses one or more of the following applications:

. PACControl, OptoOPCServer ", or OptoDatalLink —PAC Control is
Opto 22's flowchart-based programming application for creating control
programs that run on Opto 22's SNAP PAC programmable automation
controllers. OptoOPCServer is an OPC 2.0-compliant data server for data
connectivity with OPC clients. OptoDatalLink provides bi-directional data
exchange with common SQL databases.

PAC Control is part of Opto 22's PAC Project Basic  software suite, which also
includes PAC Displaym human-machine interface (HMI) software. Since PAC
Display uses the control program you create in PAC Control, no additional
changes are needed to use E1 or E2 brain boards with PAC Display.
OptoOPCServer and OptoDatalink can be purchased separately or as part of
PAC Project Professional; they also use the I/0 configuration you set up here.

+ A Modbus/TCP application such as a SCADA package.
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Legacy 1/0 Configuration for E1 and E2 Brain Boards

« A custom application written using Opto 22's memory-mapped OptoMMPW
protocol.

Configuring an E1 or E2 I/0 unit is usually a one-time task that is done as part of
commissioning a new E1 or E2 brain board for use in an I/O system. After an E1 or E2 1/0
unitis configured and its configuration information stored to flash memory, the I/0 unit is
ready for use with the kinds of applications listed above.

Requirements

This technical note assumes the following:

«  E1and/or E2 1/0 units are already attached to your Ethernet network and have been
assigned network [P addresses. If an I/0 unit does not yet have an IP address and other
network information assigned to it, configure these settings now, following the
instructions in the PAC Manager User’s Guide (Opto 22 form 1714).

«  PACManager " utility software is already installed on your computer. PAC Manager is
included on the CD shipped with E1 and E2 brain boards, and is also available as a free
download from the Opto 22 website.

Documentation

See the following guides for additional information on using E1 and E2 1/0 units and
related software applications:

For using See these guides Opto 22 form
E1 and E2 E1 and E2 User’s Guide 1563
PAC Manager PAC Manager User’s Guide, Legacy Edition 1714
PAC Control User’'s Guide 1700
PAC Control PAC Control Command Reference 1701
PAC Control Commands Quick Reference Card 1703
OptoOPCServer OptoOPCServer User's Guide 1439
PAC Display PAC Display User's Guide 1702
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For Help

If you are having trouble and cannot find the help you need in this technical note or in the
documentation listed above, contact Opto 22 Product Support.

Phone: 800-TEK-OPTO (800-835-6786  NOTE: Email messages and phone
toll-free in the U.S.and Canada)  calls to Opto 22 Product Support
951-695-3080 are grouped together and
Monday through Friday, answered in the order received.

7 a.m.to 5 p.m. Pacific Time
Fax: 951-695-3017
Email: support@opto22.com

Opto 22 website:  www.opto22.com

Preparing for Configuration

When you use ET and E2 I/O units with any protocol except Optomusx, you are
communicating with the E1’s or E2's memory map. Because the memory map was
originally developed for SNAP Ethernet brains, it is based on SNAP modules, which differ
from the modules used with the brain boards. E1 and E2 1/0 units with firmware lower than
R1.2a must be configured as if they were SNAP Ethernet I/0 units.

I/0 System Inventory

Before starting to configure E1 and E2 1/0 units, collect information on the 1/0 units in your
/0 system, including network settings and installed 1/0 modules. You can use the “E1 and
E21/0 Unit Inventory Form”on page 25 for this purpose. Copy the form for each 1/0 unit
and fill it in so all the information you need is in one place.

For each analog module on the inventory form, determine the corresponding SNAP
module and initial scaling from the following tables and write it on the form.

Analog Input Modules and Initial Scaling

For this G1 analog input module... ...select this SNAP analog input module and
initial scaling.

AD2T: 0 - 20 mA SNAP-AIMA: -20 - +20 mA

AD3 or AD3T: 4 - 20 mA SNAP-CUSTOM-AI: Mode 1

AD4: ICTD Temp. Probe SNAP-AICTD: ICTD Temp. Probe, Degrees C

AD5 or ADST: Type J TC SNAP-AITM: Type J Thermocouple, Degrees C
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For this G1 analog input module... ...select this SNAP analog input module and
initial scaling.
ADB6, AD6T, or AD6HS: 0 - 5 VDC SNAP-AIV2-i: -50 - +50 VDC
AD7:0-10VDC SNAP-AIV2-i: -100 - +100 VDC
AD8 or AD8T: Type KTC SNAP-AITM: Type K Thermocouple
ADIT: 0 - 50 mV SNAP-AITM2-i: -50 - +50 mV
AD10T2: 100 Ohm RTD SNAP-AIRTD: 100 Ohm Pt 3-wire
AD11: -5 - +5 VDC SNAP-AIV: -5 - +5 VDC
AD12: -10 - +10 VDC SNAP-AIV: -10 - +10 VDC
AD13T: 0 - 100 mV SNAP-AITM: -150 - +150 mV
AD14T: 10 Ohm RTD SNAP-AIRTD: 120 Ohm Ni 3-wire
AD15T: 28 - 140 VAC SNAP-AIVRMS: 0 - 250 VAC/VDC
AD16T: 0 - 5AAC/DC SNAP-AIARMS: 0 - 10 AAC/DC
AD17T: Type RTC SNAP-AITM2: Type R Thermocouple
AD17T: Type STC SNAP-AITM2: Type S Thermocouple
AD18T: Type TTC SNAP-AITM2: Type T Thermocouple
AD19T: Type ETC SNAP-AITM: Type E Thermocouple
AD20: Rate (Freq) SNAP-AIRATE: Rate (Frequency)

Analog Output Modules

For this G1 analog output module... ...select this SNAP analog output module.
DA3: 4-20 mA .

DA3T: 4 - 20 mA SNAP-AOA-3: 4 - 20 mA

DA5: 0-10VDC SNAP-AQOV-5: 0 - 10 VDC

DA7: -10 - +10 VDC SNAP-AQOV-7: -10 - +10 VDC

DA4: 0-5VDC .

DAAT: 0 - 5 VDC SNAP-AQOV-25: 0 - 10 VDC

DA6: -5-+5VDC SNAP-AQV-27: -10 - +10 VDC

DA8: 0-20 mA SNAP-AOA-28: 0 - 20 mA

Important Notes

E1 1/0 units—Because the E1 is not exactly like any SNAP brain, there is one limitation: to
use counters, you can use no more than eight points on the unit (similar to a
SNAP-B3000-ENET, which supports a maximum of eight digital modules on the rack). If you
are not using counters, up to 16 points can be used (similar to a digital-only
SNAP-ENET-D64, which does not support counters).
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Configuring I/0 Units

Follow the steps in each section to configure each E1 and E2 I/O unit on your network.
Note that you can include multiple ET and E2 I/O units in a single configuration file.

Configuration tree

IMPORTANT: Even if you plan on using these E1 and E2 1/0 units with PAC Control, you must
use PAC Manager to create a new configuration file, configure points, and save the configuration
to flash memory on the brain. For an E2, custom scaling (and calibrating offset and gain, if
necessary) are separate steps that require a second save to flash. Follow the steps below.

Creating a New Configuration File

1.

If PAC Manager is not already open, choose Start > Programs > Opto 22 > PAC Project
Software > PAC Manager.

In the PAC Manager main window, click the New button _Ijl or choose File > New.

In the Create New Tag Database dialog box, navigate to the location where you want
the file to be. Type a filename. Click Open.

A new configuration tree appears. (If you are familiar with PAC Control, ioControl, or
OptoControl, you'll notice that this window looks like part of a Strategy Tree.)

| PALC gel _Process e
File Edit Tools View Help
Ana B 6 o

C:\Program Files (x86)\Opto22\PAC Project 9.0\SNAP PAC Learning Center\Mair MNUM v

You can expand and collapse the folders to see or hide the I/O units and points in
them. Closing the configuration tree is the same as closing the configuration file.

To save the configuration file, click the Save button El or choose File > Save.

Once the file is saved, continue with the next section, “Adding an E1 or E2 1/0 Unit.”

TECHNICAL NOTE - Form 1576-160527 5




Legacy 1/0 Configuration for E1 and E2 Brain Boards

Adding an E1 or E2 I/O Unit

An E1 or E2 I/O unit consists of a mounting rack, plus the E1 or E2 brain board and I/0
modules mounted on it. In PAC Manager you must add an /O unit before you can
configure its modules and I/0 points.

1. Make sure the configuration file is open. On the configuration tree, double-click the
I/0 Units folder to open the Configure I/0 Units dialog box:

-
= Configure /O Units

(S

MName | Type

Port

| Address

Close I Help

| Watchdh | Description Add...
Vatchdog
Modify... |
Delete |

Import/Copy... |

110 Points. .. |
PIC Loops... |

.

J

2, Toaddanew I/O unit, click Add or double-click anywhere in the box below any listed

units.

The Add 1/0 Unit dialog box appears:
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’ ~
Add /0 Unit [
A Name: [
B Description: |
C Type: |sHaP-PAC-EB1 -
D Temp: (¢ Fahrenheit (" Celsius
E Port: 2001
F Address: |D.D.D.D
Secondary: |
Address List
Address List area — Add...
G Watchdog: & Mo (" Yes
0K | Cancel Help
- J

3. Complete the fields as follows:
A Enter a name for the I/O unit. The name must start with a letter and may contain

B
C

letters, numbers, and underscores. Spaces are converted to underscores.
(Optional) Enter a description of the unit.
Select the type of I/0 unit from the drop-down list.

For this E1- or E2-based /O unit... ...select this SNAP /O unit.

E1 brain board with:
* up to 8 digital I/0 points SNAP-B3000-ENET
» any digital point configured as a counter

E1 brain board with:
* up to 16 digital I/O points SNAP-ENET-D64
* no digital point configured as a counter

E2 brain board SNAP-B3000-ENET

Choose whether temperatures will be handled in Fahrenheit or Celsius.

Specify the communication port to use (2001, unless you have changed it for
security purposes according to the instructions in the PAC Manager User’s Guide).
Enter the I/O unit’s IP address. Leave the Secondary field blank.

The Address List area shows IP addresses of the I/0 units that should receive this
configuration. If you have I/0 units that are exactly alike (having exactly the same
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modules and features), list all of them here. That way you can download the

configuration file to all the I/O units at once.

— Toaddan IP address, click Add. (In the dialog box, you can add a single IP
address or a range of addresses.)

' h'
) Add IP Address S5
¢ Add one IP Address / Host Name
f:IPAddress:l .0 .0.0
" Host Mame: I
{~ Add a range of IP Addresses
Frarm: I - - -
To: I . . .
0K I Cancel | Help |
L "y

- Enterthe IP address(es) and click OK.
The addresses appear in the Address List area.

Select whether you want a Watchdog on the unit. The default is No (disabled). If
you select Yes, a new field appears; enter the Watchdog timeout value in seconds.
The default timeout is 0.5 seconds.

4. When information in the Add I/0 Unit dialog box is complete, click OK.

The new I/O unit appears in the Configure I/0 Units dialog box:

-
=5 Configure [/Q Units

=]

|Watd1dog |Descri|:|h'on |

Disabled

| Address
10.192.64...

| Port
Ethernet

| Mame | Type

E1_digital [0 SMAP-B30...

Help

Close I

Add...

Modify... |
Delete |

Impaort/Copy... |

1/0 Points... |
PID Loops... |
Modules 4 |
Events 4 |
SoatchPad  » |
Communications * |
Others 3 |

L9

5. Add other I/0 units or continue with the next section on configuring I/O points.
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Configuring I/O Points

Modules used with E1s and E2s have only one point per module. However, PAC Manager
was originally developed for SNAP modules, which accommodate up to four points each.
For these I/0 units in PAC Manager, each module on the E1 or E2 corresponds to the first

point (point 0) on a similar SNAP module.

EXCEPTION: Point numbering for Modbus/TCP operation starts with 1, not 0. See the E1 and
E2 Brain Board User’s Guide (Opto 22 form 1563) for more information on using Modbus/TCP

When you use the memory map with E1s and E2s, each module on the E1 or E2
corresponds to the first point on a similar SNAP module.

E1 brain boards can be used with a variety of modules. The maximum number of points
is 16 on the largest rack, as shown below.

E1 shown with G4 modules.

Sln'ce each module has'Just one point, use only the first Vodule # | Point #
point for each module in the memory map.
00 0
15 0

Module position 0

E1 with Quad Pak modules.

Quad Pak modules have four input or four output points, but each
point is treated as if it were a separate one-point module.

00 0
01 0
0 02 0
03 0 =
04 0 Y
05 0 L3
1 0 ]
06 0 [ [
07 0 : ‘@ %
08 0 -
2 09 0 |
10 0 2 [ [
" 0 ]
12 0 3
3 13 0
14 0
15 0
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E2 brain boards are used with analog G1 modules only. The largest rack (shown below)
holds 16 single-point modules.

E2 with G1 modules.
Since each module has just one point, use only the Module # | Point #
first point for each module in the memory map.
00 0
ESEEEEssEESSEEEEEEESESSEEESSSEEE
HCCCCC LT OO e e eerrr
15 0

Module position O

Adding and Configuring E1 Modules and Points

For E2, see “Adding and Configuring E2 Modules and Points” on page 13.

1. Inthe Configure I/O Units dialog box, make sure the I/O unit for the point you are
adding is highlighted. Click the 1/0 Points button.

The Configure I/0 Points dialog box appears:

T Al
= Configure I/O Points E@g
1/O Unit: | Type: ISNAP-BSUUU—EHJEI’, SMAP-ENET-RTC (analoc
Madules and Points | Type | Features / Subty... = Add... |
[00] Not Used )
Madify...
[01] Net Used —YI
[02] Nat Used Delzte |
[03] Not Used
[04] Not Used Mave To...
[05] Not Used - —I
[06] Not Used E
wpand All
[07] Net Used —I
[08] Nat Used Caollapse Al |
03] Not Used -
«| | 3

Close I Help | Calibrate. .,

W A

2. Double-click the number that represents the digital module’s position on the rack.
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-
=] Add Module

Type:

Digital Qutput
Analog Input

Module:

Digital Input

Analog Cutput

SMAP-IDCS-FAST: 2.5 - 16 VDC
SMAP-IDCS5-FAST-A: 18 - 32VDC

SMAP-IDCSD: 2.5 - 28 VDC

SMAP-IDCSMA: 10 - 32 VDC/VAC Man/Auto Switch
SMAP-IDCS-SW: Dry Contact Switch
SMAP-IDCSQ: 4 - 24 VDC

SMAP-IDCSG: 35 - 75 VAC/NDC

SMAP-IDCS5-HT: 15 - 32VDC

SMAP-IDCS-SW-MC: Dry Contact Switch
SMAP-IDCSFM: 10 - 32 WDC

SMAP-IDCSDFM: 2.5 - 28 VDC

Generic Digital Input

SMAP-IACS: 90 - 140 VDC,/VAC

SMAP-TACSA: 180 - 280 VDC/VAC

SMAP-IACSMA: 90 - 140 VDC/VAC Manfauto Switch
SMAP-TACSFM: 90 - 140 WVDC/VAC
SMAP-IACSAFM: 180 - 280 VDC/VAC

T

3. Inthe Add Module dialog box, choose the type and then choose the module:

+  Select any SNAP-IDC5 module for a digital input.

«  Select any SNAP-ODC5 module for a digital output.

4. Backin the Configure I/O Points dialog box, click the plus sign next to the new
module to expand it.
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i ™
5| Configure [/Q Points (=] = [t
1O Unit: | E1_digital IO Type: | SNAP-B3000-ENET, SNAP-ENET-RTC (analog
Module icon ~_|
i N Modules and Paints Type Features / Subty... « Add. ..
Expand or collapse points EN] [00) SNAP-IDC5: 10 - 32 VDC/VAC Digital Input Modify |
on the module by clicking — I D Nt Used
the + or - sign in the box. T 1 Not Used Delete |
T 2 Not Used
Points —  H4 3 Not Used Move Ta... |
[071] Mot Used
0Z] Not Used Expand Al
[03] Not Used
[04] Mot Used Collapse All |
[05] Mot Used -
1| | ’
Close I Help | Calibrate, ., |
e A

5. Double-click the first point (point 0) of the module you want to configure. (Remember
that points 1-3 don't apply. See “Configuring I/O Points”on page 9.)

The Add Digital Point dialog box opens.

r ™
Add Digital Point S
Mame: I A
Description: I B
L | L
Type: Input 15 Il C
Module:  [SNAP-IDCS: 10 - 32 VDC/VAC -]
Features: INone j D
Watchdog: (% No (" ves E
oK I Cancel | Help
L A

6. Complete the fields as follows:
A Enter a name for the point. The name must start with a letter and may contain
letters, numbers, and underscores. Spaces are converted to underscores.
B (Optional) Enter a description of the point.
C Type and module are already filled in for you.
D (Input points only) To use the point as a counter, choose Counter from the Features
list. Note that Quadrature Counter may appear in the Features list, but this feature

12 | TECHNICAL NOTE - Form 1576-160527




Legacy I/0 Configuration for E1 and E2 Brain Boards

cannot be used here.
For output points, leave the Features field as None.

E (Output points only) To set a Watchdog, click Yes and choose On or Off from the
drop-down list.

7. When you have completed the fields, click OK.
The new point appears in the list:

i ™
4= Configure I/C Points @E‘g
10 unit: | E1_digital IO Type: | SNAP-B3000-ENET, SNAP-ENET-RTC (analog
Modules and Points | Type | Features / Subty... « Add... |
= [} [00] SNAP-IDC5: 10 - 32 VDC/VAC Digital Input Modify...
00 oo oot | |Comer |
T 1 Not Used Delete
L1 2 Not Used
U 3 pot Used —

Maove Ta...
[01] Mot Used

[02] Not Used

Expand All
[03] Not Used
[04] Mot Used Collapse All
[05] Not Used -
<] | LlJ

FOREED

Close I Help | Calibrate...

L

8. To configure more digital points, repeat the steps. Remember for each module,
configure only the first point (point 0).

9. When you have finished adding digital points to the I/0 unit, click Close and then
Close again.

10. Click the Save button ﬂ or choose File > Save to save the configuration file.

11. Follow steps in “Saving I/0 Unit Configuration to Flash on the Brain”on page 16 to
save the configuration to the E1 brain board'’s flash memory.

Adding and Configuring E2 Modules and Points

If you don't already have an E2 I/0 unit in the configuration file, follow the instructions in
“Adding an E1 or E2 1/0 Unit”on page 6.

IMPORTANT: fyou plan to use custom scaling with any analog module, follow the steps below
to first add the modules and points and save the configuration to flash memory on the brain.
Then you'll apply custom scaling, calibrate the modules if necessary, and save the configuration
to flash again.

1. Make sure the unitis highlighted, and then click the I/0 Points button to open the
Configure I/0 Points dialog box.
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2. Inthe Configure I/O Points dialog box, double-click the number that represents the
analog module’s position on the rack.

The Add Module dialog box opens.

r A
5 Add Module =5

Type:

Digital Input
Digital Cutput
Analog Input
Analog Cutput

Module:

SMAP-IDCS5-FAST: 2.5 - 16 VDC
SMAP-IDCS-FAST-A: 18 - 32VDC

SMAP-IDCSD: 2.5 - 23 VDC

SMAP-IDCSMA: 10 - 32 VDC/VAC Man/Auto Switch
SMAP-IDCS-5W: Dry Contact Switch
SMAP-IDICSQ: 4 - 24 VDC

SMAP-IDCSG: 35 - 75 VAC/NDC

SMAP-IDCS-HT: 15 - 32VDC

SMAP-IDC5-SW-MC: Dry Contact Switch
SMAP-IDCSFM: 10 - 32 WDC

SMAP-IDCSDFM: 2.5 - 28 VDC

Generic Digital Input

SMAP-TACS: 90 - 140 WVDC/VAC

SMAP-IACSA: 180 - 280 VDC/VAC

SMAP-TACSMA: 90 - 140 VDC/NVAC Man/Auto Switch
SMAP-IACSFM: 90 - 140 VDC/VAC
SMAP-TACSAFM: 180 - 280 VDC/VAC

oK I Cancel |

T e _J

3. Choose the type (Analog Input or Analog Output) and then the corresponding SNAP
module from the list.

If you completed the inventory form earlier, the SNAP module you need to select
should be listed there. Otherwise, see “Analog Input Modules and Initial Scaling”on
page 3 or “Analog Output Modules”on page 4.

4. C(lick OK.
5. Inthe Configure I/0O Points dialog box, click the plus sign next to the new module to
expand it.

14 | TECHNICAL NOTE - Form 1576-160527




Legacy I/0 Configuration for E1 and E2 Brain Boards

ré Canfigure /O Points E‘Mw
1/0 Urit: | E2_analog_I0 Type: | SNAP-B3000-ENET, SNAP-EMET-RTC (analog
Module icon .
N
N Modules and Pairts Type Features / Subty... ~ Add... |
Expand or collapse points BN | [DI]] SNAP-AIMA ﬁnalog ot || Modify |
on the module by clicking 24 0 Not Used
the + or - sign in the box. - 241 Not Used Delete |
L [01] Mot Used
Points <] [02] Not Used Move To... |
[03] Mot Used
[04] Mot Used Expand Al
[05] Mot Used
[D6] Mot Used Collapse all |
[07] Mot Used -
<| | _>|J
Close I Help | Calibrate. .. |
L9 Iy

6. Double-click the first point (point 0) for the SNAP module you just added. Remember
that other points on the module don't apply (see “Configuring I/0 Points” on page 9).

The Add Analog Point dialog box opens.

' ™y
Add Analog Point (e

Mame: I | A
Description: I B
Type: IInput _|I C
Module:  |SNAP-AIMA: -20 - +20 mA |

. I—mﬁ. Scaling————
Default |
D Zero Scale: I -20
Custom. .. |
Full Scale: IZI.’J

Watchdog: % No € ‘es E
oK I Cancel | Help
w .

7. Complete the fields as follows:
A Enter a name for the point. The name must start with a letter and may contain
letters, numbers, and underscores. (Spaces are converted to underscores.)
B (Optional) Enter a description of the point.
C Type and Module are inserted for you.
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D Scaling will be configured in a later step. Don’t do it now. Scaling is a
two-step process. The default point scaling must be saved to the I/0 unit first; later you
can scale the points and save the configuration again.

E (Outputs only.) To set a Watchdog on this point, click Yes, and define the value to
be assigned to the output if the Watchdog is triggered. A Watchdog is triggered if
no communication activity is detected for the amount of time specified in the
Watchdog field of this point’s I/0 unit.

8. When you have completed the fields, click OK.
The new point is added:

= Configure /O Points E= ﬂ
10 Unit: | E2_analog_10 Type: | SNAP-B3000-ENET, SNAP-ENET-RTC (analoc
Modules and Points | Type | Features / Subty... « Add... |
B . [0D] SMAP-AIMA Analog Input Modify...
g 0 Tark leve 20 20mA
1 Mot Used Delete
[07] Mot Used
02] Not Used —

[03] Not Used
[04] Not Used
[05] Mot Used
[06] Mot Used Collapse All

[07] Mot Used -
4| | »

Close I Help | Calibrate...

e 4

Expand All

L

Point types and features are shown in the Features/Subtype column.
9. Toadd more analog points, repeat the steps.
10. When done, click Close and then Close again.
11. Click the Save button ﬂ or choose File > Save to save the configuration file.

Note the location where you saved the file so you can open it in PAC Manager to
complete scaling (and calibrating, if necessary) later.

Saving I/0 Unit Configuration to Flash on the Brain

IMPORTANT: You must now download the current I/O unit configuration to the brain board
and save it to flash memory. If you're configuring an £2 analog I/O unit, this is an intermediate
step; after you've finished scaling analog I/0 points (and calibrating them, if necessary), you will
again need to download the I/O unit configuration to the brain board and save it to flash.

1. Choose Tools > Send Configuration to I/0 Unit to save the I/O unit configuration to
the E1 or 2 brain board's flash memory.
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p
=] Send Configuration to Opto 22 Device [ﬂ
Mame | Description | Port | Address List | Send I
E1_digital 10 2001 10.192,64.66
E2_analog_I0 2001 Clear Flash |
Cloze |
Help |
¥ Save to Flash Timeout (msec):
[” Restart Device I 10000
A

L

2. Inthe Send Configuration to I/O Unit dialog box, do the following:
a. Select the configuration name from the list on the left.
b. Make sure the Save to Flash checkbox is selected.
c. Select the IP address of the I/0 unit that will receive the configuration.
d. Click Send to send the configuration to the I/0 unit.
3. (lick Close.

To configure analog point scaling and offset and gain, if necessary, continue with the next
sections.

Using Custom Scaling

Scalable analog modules can be set to show something other than the actual inputs or
outputs. For example, you could scale the readings of a voltage input point to measure its
input as a percentage between 0% and 100% rather than volts.

NOTE: Custom scaling has no effect on the resolution or accuracy of the module.

IMPORTANT: The range of the G1 module is usually different from the range of the
corresponding SNAP module, so scaling isn’t intuitive. For example, the AD2T has a range of 0—
20 mA, but the equivalent SNAP-AIMA’s range is -20 to +20 mA.

Counts may be different as well; for example, all G1 analog modules are 0-4095 counts, but the
SNAP-CUSTOM-AT: Mode 1 that is equivalent to the AD3 shows -25,000 to +25,000 counts.

Follow the steps and examples in this section to make sure your points are scaled correctly.

1. In PAC Manager, open the configuration file you just saved. If you wish, choose File >
Save As and add “scaled”to the filename.
You will then have two configuration files, one with the points before scaling and one
with the points scaled. That way, if you ever have to download the configuration to
this brain again, you'll have both files you need to download: first the non-scaled file
and then the scaled file.
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2. Inthe configuration tree, double-click the Points folder for the I/0O unit you will
configure,

-
@ PAC Manager - E2 Configuration_scaled

File Edit Tools View Help

olesld] #[%la] B @)

=
" e N
E2 Configurati... | = | 5] Configure /0 Points EIEIQ
=I5 E2 Configuration_
BB 1jo Unit: [E2_analog 10 Type: | SNAP-B3000-ENET, SNAP-ENETRTC (analot

El_digital |

5| EZ_a:a.Iog Modules and Points | Type | Features / Subty... « Add. . |
oints [00] SNAP-AIMA Analog Input :
& Ds -Els [07] SNAP-AIV24 Analog Input ﬂl
- R GO | | 00-.i00vic Delete
221 ot Used —I
Oa (021 SNAP-ADA-23 Analog Cutput Move To... |
[03] Mot Used =
[04] Mot Used Expand Al
[05] Not Used
[06] Mot Used Collapse Al
[07] Mot Used -
< | LlJ

Pl

Help | Calibrate. ..

3. Now double-click the analog I/0 point you want to scale.

4. Inthe Edit Analog Point dialog box, select the Module that has “(Scalable)”at the end
of the description, and then click Custom.

g ™y
Edit Analog Peint S

Mame: I F17

Description: I

Type: I Input b I

Module: SMNAP-AIVZ: -100 - +100 VDC LI
SMAP-ATV24: -100 - +100 VDC

Units: SMAP-AIV24: -50 - +50 VDC

[l Default |
Zero Scale: | -100
Custom. .. |
Full Scale: I 100

Watchdog: % No & Yes

oK I Cancel Help

L - A
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5. Complete the fields in the Scale Analog Readings dialog box.

' A
Scale Analog Readings ﬁ
A Scaled Units: Im
Lower Value
B Actusl:  [-100 | voc
C Scaled: [0 [voc
—Upper Value
D Actual: | 100 [voc .
E Scaled: |0 jvoc
oK I Cancel | Help |
L &
A Enter new engineering units for the module.
B In most cases, enter the actual lower value of the G1 module’s range (NOT the

equivalent SNAP module’s range). Exceptions: See the example tables on page 20.
C Enter the new scaled lower value. This value can be any floating point value.
D Enter the actual upper value of the G1 module’s range.
E Enterthe new scaled upper value. This value can be any floating point value
greater than the scaled lower value.

In the example at right, the point : )
Scale Analog Read
isonan AD7 module, which has a Smeaed s
range of 0—10 VDC. Itis scaled to Scaled Units: [percent
percent with a lower value of 0 Lomer Value
and an upper value of 100.
Actual: [0 {voc
When the actual readmg. is10 scaec: [0 [Fercent
VDG, the scaled reading is 100%.
6. C(lick OK. —Upper Value
The new custom-scaled units B =
appear in the Edit Analog Point Scaled: | 100] | Percent
dialog box.
0K I Cancel | Help |
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Notice the new units of percent.
Don't be concerned about the new
zero-scale and full-scale values (in
this example, -1000 and +1000).
These values are extrapolated from
the values you entered. As long as
you entered the correct values, the
point will give accurate readings.

' ™y
Edit Analog Point S
MName: IFl?
Description: I
Type: IInput vl
Module:  [SNAP-AIV2-i: -100 - +100 VDC (Scalable) v |
Scal
Units: IPercent na
Default |
Zero Scale: | -1000
|
Full Scale: 1000
Watchdog: % Mo {7 Yes
0K | Cancel | Help |
LN I’y

7. To calibrate offset and gain, continue with “Calibrating Offset and Gain”on page 21.
Otherwise, skip to “Saving the I/0 Unit Configuration”on page 23.

Custom scaling examples: 0-100% Engineering Units

Percent Percent
AD2T 0 20 0 100
05 [ o [0 | 0 | | gmsomenzsenmaessaraans 2
AD6 Use 0 and +10 (instead of 0 and +5) for
ADGT 0 10 0 100 the "Actual" values.
ADBHS
AD7 0 10 0 100
ADIT 0 50 0 100
AD11 -10 10 0 100 ::]see";‘j C(Ljaar:'cli;a} 3 e(:-1stead of -5 and +5) for
AD12 -10 10 0 100
AD13T 0 100 0 100
AD15T 28 140 0 100
AD16T 0 5 0 100
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Custom scaling examples: 300-4500 PSI Engineering Units

G1 Lower Upper Lower Upper Notes

Module | Value Value Value Value

Actual Actual Scaled Scaled

PSI PSI
AD2T 0 20 300 4500
AD3 Use 5000 and 25000 (instead of 4 and 20)
AD3T 5000 25000 300 4500 for the "Actual" values.
AD6 Use 0 and +10 (instead of 0 and +5) for
ADGT 0 10 300 4500 the "Actual" values
AD6HS ’
AD7 0 10 300 4500
AD9IT 0 50 300 4500
AD11 10 10 300 4500 Use"-10 an'cli +10 (instead of -5 and +5) for
the "Actual" values.

AD12 -10 10 300 4500
AD13T |0 100 300 4500
AD15T |28 140 300 4500
AD16T |0 5 300 4500

Calibrating Offset and Gain

The E2 brain board can calibrate analog input points. If a -50 mV to +50 mV input receives
signals that are slightly off (not exactly -50 mV at the lowest point, for example), the offset
and gain can be calculated so that values will appear accurately when read.

Offset and gain values affect engineering units. For a temperature input, engineering units
are in degrees C or F, depending on how the brain is configured. You can manually set
offset and gain or have the brain automatically calculate and set them for you.

IMPORTANT: To calibrate the point, the /0 unit must be turned on and attached to the
network, and you must have access to it to use the calibrator. After calibrating, save the
configuration to flash so that it will not be lost when power is turned off. Since each calibration
is for a specific point on a specific E2 brain board, the result cannot be saved to the configuration
file and cannot be sent to any other brain board.

Calculate offset first, and then calculate gain. The offset must be calculated at the point’s
low scale, and the gain must be calculated at the point’s high scale.
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1. Inthe Configure I/O Points dialog box, highlight the analog input point you want to

calibrate.
3| Configure /O Paints EI
140 Urit: [Preprocess Type: |SHAP-PACR [analog/digital]
Modules and Points I Type | Features / Subty... = add.. |
[} [00] SNAP-IDC5: 10 - 32 VDC/VAC Digital Input Modif...
= gl [01] SNAP-AIV- Analog Input
b 0 Fowmeter A | ]| 10-+10VIC Delete
241 Not Used
02] Mot Used Move To...

[03] Not Used
[04] Mot Used
05] Not Used
[06] Mot Used Collapze All

[07] Not Used -
4| | »

Cloze I Help | Calibrate. ..

Expand &ll

b

2. (lick the Calibrate button in the lower-right corner of the dialog box.

| Calibrate Analog Input - Flowmeter_A (Module 1, Point 0)

Automatically Caleulate Set Offzet

3 Use a calibratar to input the: signal
" carresponding to zero Engineering Units Cloze

" Gain - Use a calibrator ta input the signal
correzponding bo the point's masimum
naminal value

/

MOTE: ou muszt zet the Offzet first. Mare >

3. To have the Ethernet-based brain calculate offset and gain, do the following:

a. Use a calibrator to input minimum scale on the analog input point (for example, 0
degrees F or C for a temperature input). Click Offset, then click the Set Offset
button.

b. Use the calibrator to input maximum scale on the analog input. Click Gain, then
click the Set Gain button.

4. To manually set offset and gain, do the following:
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a. C(lick the More button.

| Calibrate Analog Input - Flowmeter & (Module 1, Point0) |23
Set Offzet
o
Cloze
~
MOTE: 'ou must zet the Offzet first. << Less
td anually Set
Offzet: |0 Gair: |0

b. Enter the Offset value. Click the Set Offset button.
c. Enter the Gain value. Click the Set Gain button.

5. When you have finished calibrating the point, close the dialog box to return to
configuring I/0 points.

NOTE: To store offset and gain values permanently, you must save the change to flash when you
send the configuration data to the I/0 unit (next section)

Saving the I/0 Unit Configuration

The final step in setting up an E1 or E2 I/O unit is to save the configuration information,
both as a file and in the E1 or E2 brain board’s flash (non-volatile) memory.

1. To save the configuration file, click the Save button ﬂ or choose File > Save.

Note the location where you saved the file. You can open this file in PAC Manager to
restore the configuration to an /0O unit, and you can also import the file into PAC
Control, OptoOPCServer, and OptoDataLink software.

2. Tosave the I/0 unit configuration to the E1 or E2 brain board's flash memory, choose
Tools > Send Configuration to I/0 Unit.
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=] Send Configuration to Opto 22 Device

Name | Description | Port | Address List | Send
E1_digital 10 2001 10.192.64.66

E2_analog_ 10 2001 Clear Flash

Cloze

dii|f

Help

¥ Save to Flash Timeout (msec):

I Restart Device 10000

L

3. Inthe Send Configuration to I/O Unit dialog box, do the following:
a. Select the configuration name from the list on the left.
b. Make sure the Save to Flash checkbox IS selected.
c. Select the IP address of the I/0 unit that will receive the configuration.

4, (lick Send to send the configuration and have it saved to flash memory.

Note on Point Numbers

In most cases points appear in the format module xx, point 0 (see page 9). But in some
cases, like a Digital Bank or Analog Bank read or in certain tables in PAC Control, you'll see
points numbered differently, like this:

Module position on E1 or

E2I/Orack:01 2|34 (5|6 |7|8|9(10|11|12[13|14|15

Corresponding SNAP

) 104 |8 |12|16|20|24|28|32|36|40|44|48|52 |56 |60
point number:

What's Next

Configuration of the E1 or E2 I/0 unit is complete. Depending on your I/0 system and
application(s) you plan to use the I/0 unit with, do the following:

+  Forusing a Modbus/TCP application, see the Modbus/TCP chapter in the £7 and £2
User’s Guide (Opto 22 form 1563).

«  Forusing a custom application based on OptoMMP, see the OptoMMP Protocol Guide
(Opto 22 form 1465).

«  Forusing PAC Control or OptoOPCServer, see the PAC Control User’s Guide (Opto 22

form 1700) and the OptoOPCServer User’s Guide (Opto 22 form 1439). In both guides,
refer to the information on importing .OTG files from PAC Manager.
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E1 and E2 I/O Unit Inventory Form

Brain Board and Network Settings

Brain board model E1 E2 IP address
Physical Location Subnet mask
MAC address 00-A0-3D-00- - Gateway address

I/0 Rack with G1 Analog, G1 Digital, or G4 Digital I/O Modules

Module Part Input Corresponding Point Digital Analog Scaling Information
Position Number or Output SNAP module Number | Counter? | Scaling?
: o |
1 o | e
z o |
; o | e
: o | e |
: o |
: o | e
7 o | e |
; o |
: o | e
o o | e |
: o |
2 o | o e
s o | e |
r o |
s o | e
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I/0 Rack with Quad Pak Digital I/0 Modules

Module Part Input Corresponding Point Digital
Position Number or Output SNAP Module Number | Counter?
Yes
0 No
Yes
0 No
0
Yes
0 No
Yes
0 No
Yes
0 No
Yes
0 No
1
Yes
0 No
Yes
0 No
Yes
0 No
Yes
0 No
2
Yes
0 No
Yes
0 No
Yes
0 No
Yes
0 No
3
Yes
0 No
Yes
0 No
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