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Summary of Changes

IBM Softcopy Reader V3.6 driver level SCRV3_081506 contains the following
changes and enhancements:

¢ The 'Quick Search’ function now exploits the Shelf Index (.BKI file), if present,
when used to search across documents on extended shelves (.XKS files). PDF
files (as opposed to corresponding BookManager Book files) are now listed as
search results when Quick Searching indexed extended shelves.

* If the IBM Advanced Linguistics Search (ALS) Plug-in for Adobe V1.3 (or later)
is installed, any PDFs selected from the hit list will launch the ALS Plug-in (from
within Adobe Reader) to provide a list of ranked and highlighted search hits
within the selected PDFE.

* Regular searching of extended shelves (with or without an associated shelf
index) now searches BookManager Book files, if present, corresponding to the
documents on the shelf.

* Various service enhancements have been rolled up into this release of Softcopy
Reader. See the readme file for details.

© Copyright IBM Corp. 2000, 2007 \%
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Chapter 1. Overview

IBM Softcopy Reader is made up of two programs, Book Reader and Shelf
Organizer. This guide explains how to install and use it under Windows or Linux.

Book Reader

Book Reader allows you to open softcopy books created with one of the IBM
BookManager® Build programs. You can:

* View and navigate through the softcopy books and PDFs online
* Do searches within the book

* Create notes

* Copy text

e Print text selections, a section, or the entire book

shows an example of the Book Reader window.

%2 X:\Books'ab0in011.boo: Installing, Managing, and Using the Online Library - IBM Softcopy Reader Q@
File Edit Wiew Mavigate Search Motes Help
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& Installing, Managing, and Using the On : 1.1 Chapter 1. What Is the IBM Online Library? sl
COWER Book Cover The "IBA Online Library" contains IBAL publications and product books in softcopy format, organized into collections and
NOTICES Motiess % packaged on CO-ROMs or DvDs, Originally, the softcopy collsctions contained only books svailable in Bookihanager format.
EDITION Edition Notice Increasingly, collections akao contain books available in other formats, such as Partable Data Format (PDF) and HTAAL,
CONTENTS Table of Contents
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# 2.0 Part 2, Installing Softcopy Toal:
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# 4.0 Part 4. Using BookManager and

# APPENDIXT Part 6. Appendixes

All the Bookianager books in these softcopy collsctions can be wviswed and searched slectronically, without changing
them, on workstations and portable laptop PCs {running Windows), host systems (running zf05, 057390, zV, Wi, or CICS),
and the A5/400 System. The same book can be wiswed at vour workstation or terminal using any of the following methods:

# The 1B, Softcapy Reader, which is provided at no charge with the lbrary on the softcapy collsctions
# The IB# Bookitanager READ component of z/05 or 05/330

# The |BM Bookdanager READ licensed program for Wit

# The Library Server component of z/O5 YIRS ar z/ Q5.8 WIRS

# The IBM Bookitanager BookServer component of /05 W1R4 or earlier, /05 e VR4 or earlier, or 057330
# The Library Server for Multi Platform licensed programs for Linux, AlX, and Windows

# AS/400 InfoSeeker, which is provided as a part of the Operating System/400 in Yersion 3 and through, but not
beyond, Version 4 Release 3

Think of the 1BM Online Library as you would think of the public lbrary in your community, & public ibrary houses large
numbers of books organized into a variety of collections by subject, Each collection occupies one or more bookshelves,
The bookshelves contain the books. The public library has a libraran and tools to help you discover what is available, and
find what you want, The B Online Library, ike your community library, also contains large numbers of publications and
product books organized into collections. But, the [Bi Online Library is not a big building or a large room; it's little
packages of CO-ROMs and CVDs, It's not on long rows of shelves and stacks of books; it's online. It's not up the street or
down the hally it's rght under vour fingertips,
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Figure 1. Book Reader main window

Shelf Organizer

© Copyright IBM Corp. 2000, 2007

Shelf Organizer allows you to specify the locations (paths) of all of the books,
PDFs, shelves and shelf indexes you want to use. You can specify the paths of the
books, PDFs, shelves and shelf indexes on:

* Internal hard disk drives (C:, D:, etc.)

¢ CD-ROM drives on your workstation or on a network
 External hard disk drives on a network

* Other storage devices that can be attached to your system
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With the Shelf organizer, you can manage your softcopy libraries in the following

ways:

* Specify the location (paths) of all books, PDFs and shelves located on your
workstation, on a network, or an external storage device

* Organize (sort) your shelves by name, date, or title

* Organize (sort) your books and PDFs by name, date, title, or document number

* Filter (display a subset of) your shelves by name, date, or title

* Filter (display a subset of) your books and PDFs by name, date, title, or
document number

¢ Create your own shelves

* List shelves

* Delete shelves

e Import books and PDFs into a shelf

* Search shelves or selected documents (regular search)
 Search indexed shelves (quick search)

* Move books between bookshelves, and PDFs between extended shelves

shows an example of the Shelf Organizer window.
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Figure 2. Shelf Organizer main window




When to Use Each Program

Functions Book Reader Shelf Organizer

Open a shelf Yes

Open a book Yes Yes

Open a PDF file No Yes

Create a new shelf Yes

Search a book Yes (single book) Yes (multiple books)

Search a PDF file No No

Search an unindexed bookshelf Yes

Search an indexed bookshelf Yes

Search an unindexed extended shelf Yes (regular search
only, for books)

Search an indexed extended shelf Yes (quick search for

PDFs or regular
search for books)

Create a note in a book Yes
Use a bookmark Yes
Print a topic Yes
Copy a topic to clipboard Yes
Save a topic as HTML Yes

Chapter 1. Overview 3
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Chapter 2. Installing IBM Softcopy Reader

The IBM Softcopy Reader can be installed on a workstation with Microsoft®
Windows® 2000 or Windows XP or Red Hat Linux .

When you install Softcopy Reader, these items are installed on your workstation:

* Readme file—contains the latest information on the product and installation
instructions

* User's Guide—explains how to use the Softcopy Reader
* Book Reader program—allows you to view and search online books and PDFs

* Shelf Organizer program—allows you to view and manage online shelves, and
view or search the online books or PDFs they contain.

On Windows, these options can be selected through the Windows menu Start >
Programs > IBM Softcopy Reader.

Software and hardware requirements

Required software
Operating systems - one of the following:
* Microsoft Windows 2000 or Windows XP

* Red Hat Linux 9.0 or higher, with Sun® Java Runtime Environment’ " 1.4.1 or
higher, or IBM JRE 1.4.2 or higher.

Note: Starting with the March 2003 IBM Online Library Collection Kits, the
Windows version of the Shelf Organizer and Book Reader programs will run
in the native Windows environment. You no longer need to have the Java
Runtime Environment installed on your Windows machine.

Optional software

+ On Windows, Adobe® Reader® is required if you plan to view PDF files. If you
plan to automatically search them, via shelf organizer, the IBM Advanced
Linguistics Search Plug-in for Adobe V1.3 (or higher) is also needed.

* On Linux, any PDF reader program must be configured with Softcopy Reader if
you plan to view PDF files.

Required hardware

* A personal computer (PC) capable of running Windows 2000, Windows XD, or
Red Hat Linux 9.0 or higher.

* Display device supported by Windows 2000 or Windows XP, or Red Hat Linux
9.0 (VGA or better resolution).

* Any pointing device supported by Windows 2000 or Windows XP, or Red Hat
Linux 9.0.

* A minimum of 256MB of RAM.
* An additional 100MB of storage for Softcopy Reader.

Note: A total of 150MB of free space is required to run the install program.

© Copyright IBM Corp. 2000, 2007 5



* One or more CD-ROM drives supported by Windows or Red Hat.

Optional hardware
A printer that is supported by Windows or Red Hat.

Recommended installation steps

This is the recommended sequence for installing IBM Softcopy Reader:

1. Remove any previous versions of IBM Softcopy Reader, and beta versions of
Softcoii Reader for Java. See [Chapter 5, “Uninstalling IBM Softcopy Reader,’

2. Install IBM Softcopy Reader - this program can be downloaded from IBM
Softcopy Collection Kits, and from the IBM BookManager pages on the IBM
Web site (the latest level will be on the IBM Web site).

3. Start and run Book Reader or Shelf Organizer.

Specifying paths to books, PDFs, shelves and shelf indexes

During the installation process you will be asked to specify the locations (path
names) for the books, PDFs, shelves and shelf indexes that you wish to access.
These items can reside on:

e The hard disk drives attached to your system, for example, C:,D:. (For Linux,
these are the hard disk drive mount points.)

* CD-ROM drives attached to your system (CD-ROM drive mount points)

* External hard disk drives or CD-ROM drives that you can access through a
network (you may have multiple CD-ROM drives you want to access)

¢ Other storage devices that can be attached to your system

For Windows, you can specify the path information during installation, or when
you run the program. For Linux, you specify the path information when you run
the program.

Any path names that you supply must be valid paths; that is, the directories must
already exist in the drives specified.

If you have more than one CD-ROM drive, you can add the paths to them.

If you plan to copy files to your hard disk, you can add hard disk drive paths as
well. Define the directories on your hard disk drive first. For example, if your hard
disk drive is C and a second CD-ROM drive is E, the preceding example would
now be:

D:\BOOKS;D:\PDF;D:\SHELVES;C:\BOOKS;C:\PDF;C:\SHELVES;E:\BOOKS;
E:\PDF;E:\SHELVES

You will also be asked to specify the drive letter of your primary CD-ROM drive,
and to select the default directory shown in the window to save any notes you
create in the books, or specify your own user-writable directory.

You have the option to specify the drive letters for your CD-ROM drives. While
optional, specifying the drive letter is recommended, particularly when using the
IBM Online Library Collection CD-ROMs, so that the Shelf Organizer knows to
refresh its list of Shelves when the CD in the CD-ROM drive is changed.

6 IBM Softcopy Reader User’s Guide



If you already have the IBM Library Reader installed on your system, specify if
you would like to make the IBM Softcopy Reader the default reader.

Installing IBM Softcopy Reader on Windows platforms

These procedures allow you to install the IBM Softcopy Reader, which consists of
the Book Reader and Shelf Organizer, on your system. The install program can be
downloaded for free from:

¢ An IBM Online Library Collection Kit CD-ROM

« The IBM BookManager pages on the IBM Web site: |http:// www.ibm.com/|
[software /applications /office /bkmgr/softcopyread.htm]|

Windows Administrator authority

New from IBM Softcopy Reader V3.4 is the capability of users without Windows
Administrator authority to both install and run IBM Softcopy Reader. When
installing IBM Softcopy Reader, select the option "to install to the current user” for
a user-specific installation, or select "All Users” to do a system-wide installation
(requires Administrator authority).

IBM Softcopy Reader now uses configuration files specific for each user in the
user’s Documents and Settings home directory. You will need access to some user
writable disk space and authority to modify the user’s specific Windows registry
hive (HKEY_CURRENT_USER).

Most users have this authority by default. System-wide installations need some
user writable disk space and the authority to modify the Windows Registry hive
(HKEY_LOCAL_MACHINE).

This may require the person doing the installation to have Administrator authority
at installation time.

Installing from an IBM online library collection kit CD-ROM

IBM Online Library Collection Kit CD-ROMs contain a copy of the IBM Softcopy
Reader installation program. If the collection kit is made up of several CDs, refer
to the documentation that came with it to see which CD-ROM contains the
installation program. On most collections it will be on the first CD-ROM of the set.

These instructions assume that your hard disk drive is C and your CD-ROM drive
is D. If they are not, substitute the drive letters you are using for the letters shown
in the examples.

1. Start the Windows Program

2. From the IBM Online Library collection, insert the CD-ROM containing the
Softcopy Reader installation program, into the CD-ROM drive on your PC.

3. Click Start on the Windows task bar.

4. Click Run.

5. In the Run window, if the following path does not appear:
d:\ilrjavalilrjava.exe

type it in.
6. Click OK.

A window opens, with this message:

Chapter 2. Installing IBM Softcopy Reader 7
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The InstallShield Wizard will install IBM Softcopy Reader
on your computer. To continue click Next.

7. Click Next and follow the instructions on the Installation window to specify
path names and other options.

8. When the installation is complete, you can start using Book Reader and Shelf
Organizer. You do not have to reboot your system.

Icons for the Book Reader and Shelf Organizer are placed on your desktop during
installation.

Downloading and installing from the IBM BookManager web
site
You can download the latest level of the IBM Softcopy Reader from the IBM
BookManager pages on the IBM Web site as follows:
1. Start the Windows program.

2. Open your Web browser and go to the IBM BookManager Web page:
[http: / /www.ibm.com/software /applications/ office /bkmer / softcopyread.html|

3. Click Download Softcopy Reader for Windows.

The Save As window will open.

4. Select a drive and folder on your system to download the executable Softcopy
Reader installation file (ilrjava.exe), then click Save. The Softcopy Reader file
will be downloaded to this drive and folder on your system.

Click Start on the Windows task bar.
Click Run.
Click Browse.

© N O

Select the drive and folder you specified in Step 4 to save the file, then
highlight the ilrjava.exe file and click Open.

The correct path to the ilrjava.exe file should be displayed in the Run window.
9. Click OK.
A window opens, with this message:

The InstallShield Wizard will install IBM Softcopy Reader
on your computer. To continue click Next.

10. Click Next and follow the instructions on the Installation window to specify
path names and other options.

11. When the installation is complete, you can start using Book Reader and Shelf
Organizer. You do not have to reboot your system.

Icons for the Book Reader and Shelf Organizer are placed on your desktop during
installation.

The installation program also establishes the necessary file associations with
appropriate content type settings to ensure that Softcopy Reader is launched when
Books or Shelves are selected from the user’s desktop, or accessed from a browser.

Problems starting Shelf Organizer or Book Reader

Most startup problems are related to Softcopy Reader accessing a version of the
JRE (Java Runtime Environment) that is not at the minimum prerequisite level, or
not being able to access a JRE at all. Some users” workstations may either have no
JRE installed at all, or have one or more different versions of the JRE in directories
that are not known to the user (such as C:\windows\system32). For this reason
more than one level of the JRE may be found at different locations in the Windows
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PATH environment variable. This has been known to cause problems with IBM
Shelf Organizer startup and hence Softcopy Reader startup.

Installing IBM Softcopy Reader on Red Hat Linux platforms

These instructions assume Red Hat Linux 9.0 or later, and hereafter is referred to
as Linux. These instructions assume a non-root user named AUser, whose home
directory is at /home/AUser. Also, a Sun JRE of 1.4.1 or greater is a pre-requisite
for the Linux version (not for the Windows version). Download and install, if
necessary, the JRE as per the manufacturer instructions, and ensure the java
executable can be run from where it is installed.

Note: IBM Softcopy Reader for Linux is fully contained within one directory
structure.

Installing from an IBM online library collection kit CD-ROM

Starting in September, 2004, IBM Online Library Collection Kit CD-ROMs contain a
copy of the IBM Softcopy Reader compressed tar file. If the collection kit is made
up of several CDs, refer to the documentation that came with it to see which

CD-ROM contains the installation compressed tar file. On most collections, it will
be on the first CD-ROM of the set.

These instructions assume the product will be installed at /opt/scr and the
CD-ROM mount point is at /mnt/cdrom. If they are not, substitute the mount
points as appropriate.

1. Start Red Hat Linux.
2. Download and install the Sun JRE 1.4.1 or higher.

3. Insert the CD-ROM containing the Softcopy Reader compressed tar file, into
the CD-ROM drive on your PC.

4. Open a terminal console window. In Red Hat Linux, this can be done by
clicking the Run program option from the start menu by typing konsole.

5. Decide on an installation directory. These steps assume the program will be
installed under /opt/scr. For most Red Hat installations, this will require root
user authority. If you do not have root user authority, select a directory that
you can write to. The following steps assume root user authority. If you need
to switch to root user, do so with the su command.

6. From the terminal console, type the following commands:

cd /opt
mkdir scr
cd scr
tar -zxvf /mnt/cdrom/ilrjava/ilrjaval.tgz

7. There is limited support for file association under Linux. To do file
association, first edit the hlcb.sh.desktop and hlcs.sh.desktop files found in the
Install directory, changing the path specified under the lines starting with
“Exec=" and “Icon=" to the path specified when untarring the Softcopy
Reader package.

Note: If the Softcopy Reader package is untarred to /opt/scr, this step is not
necessary.

8. Next, copy both files to a directory location under one of the following
directories, depending on who will be using Softcopy Reader:

Directory User
/usr/share/applnk-redhat All KDE users

Chapter 2. Installing IBM Softcopy Reader 9
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11.

/usr/share/gnome/apps All Gnome users
/etc/X11/applnk All users
~l.kde/share/applnk-redhat =~ Current user when KDE is running

~/.gnome/apps Current user when Gnome is running
Have every user do steps 9-11.

Note: Before attempting to run Softcopy Reader, check that you have a setting
for the environment variable LD_LIBRARY_PATH. To do this, run the
following command:

echo $LD_LIBRARY_ PATH

If LD_LIBRARY_PATH is not set, set it to the sys directory where you

installed SCR, as in this example:

export LD_LIBRARY PATH=/opt/scr/sys
Add “/opt/scr/sys”and the Sun JRE to the user path as appropriate.
Run the Shelf Organizer by typing “hlcs.sh”. Add any paths that you may
need later, such as “/mnt/cdrom”, to the list of User Defined Directories. To
do this, select Active Directories > User Defined Directories from the menu
bar. If you intend to view PDF files, select a viewer by selecting Edit >
Document Type Preferences from the menu bar.

When installation is complete, you can start using Book Reader and Shelf
Organizer. It is not necessary to reboot your system.

Downloading and installing from the IBM BookManager web

site

Start the Linux system.

Open your Web browser and go to the IBM BookManager Web page:
[http:/ /www.ibm.com /software /applications/ office /bkmer /softcopyread.html|

Select the Softcopy Reader product, and then click the link Softcopy Reader
for Linux.

Click the link to Softcopy Reader for Linux Download.
The File Download window will open.
Click Save. The Save As window will open.

Select a suitable place on your system to download the .tgz file, then click
Save.

The Softcopy Reader file will be downloaded to this location.

Open a terminal console window. In Red Hat Linux, this can be done by
clicking the Run Program option, then typing “konsole”.

Enter the following commands in the terminal console:

mkdir installdirectory
cd installdirectory
tar -zxvf place_downloaded to/ilrjaval.tgz

where:

installdirectory is the directory where the SCR program will reside
place_downloaded_to is the directory to which the .tgz file was saved

There is limited support for file association under Linux. To do file
association, first edit the hlcb.sh.desktop and hlcs.sh.desktop files found in the
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10.
11.

12.

Install directory, changing the path specified under the lines starting with
“Exec=" and “Icon=" to the path specified when untarring the Softcopy
Reader package.

Note: If the Softcopy Reader package is untarred to /opt/scr, this step is not
necessary.

Next, copy both files to a directory location under one of the following
directories, depending on who will be using Softcopy Reader:

Directory User
/usr/share/applnk-redhat All KDE users
/usr/share/gnome/apps All Gnome users
/etc/X11/applnk All users

~l.kde/share/applnk-redhat =~ Current user when KDE is running

~/.gnome/apps Current user when Gnome is running
Have every user do steps 10-12.

Note: Before attempting to run Softcopy Reader, check that you have a setting
for the environment variable LD_LIBRARY_ PATH. To do this, run the
following command:

echo $LD_LIBRARY PATH

If LD_LIBRARY_PATH is not set, set it to the sys directory where you
installed SCR, as in this example:

export LD_LIBRARY_PATH=/opt/scr/sys
Add “/opt/scr/sys”and the Sun JRE to the user path as appropriate.

Run the Shelf Organizer by typing “hlcs.sh”. Add any paths that you may
need later, such as “/mnt/cdrom”, to the list of User Defined Directories. To
do this, select Active Directories > User Defined Directories from the menu
bar. If you intend to view PDF files, select a viewer by selecting Edit >
Document Type Preferences from the menu bar.

When installation is complete, you can start using Book Reader and Shelf
Organizer. It is not necessary to reboot your system.

Running the programs and viewing the documentation

To run "Book Reader” choose: Run Program and type "hlcb.sh”
To run "Shelf Organizer” choose: Run Program and type "hlcs.sh”

To open the "User’s Guide” (in the Book Reader), choose: Run Program and type
"hlcb.sh”, and after the Book Reader is launched, click Help > User’s Guide.

Note: You can also open books in the Book Reader from within the Shelf

Organizer.

Chapter 2. Installing IBM Softcopy Reader 11
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Chapter 3. Using Shelf Organizer

This chapter explains:

* An overview of the Shelf Organizer Window Menu and Tool bars
¢ Active and User Defined Directories, Auto Refresh

* Opening a shelf

* Creating a shelf

* Searching multiple books in a single bookshelf (or across multiple bookshelves)

Overview—Shelf Organizer window, menu and toolbars

This section shows you what the Shelf Organizer window looks like and the
functions of the menu and toolbars.

Note: If Shelf Organizer does not seem to start correctly, refer to |”Pr0blems|
[starting Shelf Organizer or Book Reader” on page 8.

The Shelf Organizer window

There are five main sections of the Shelf Organizer window.
Menu Contains menus of all the functions of Shelf Organizer.

Toolbar—List of Shelves

Contains icons that provide shortcuts to common functions pertinent to the
shelves.

Also contains Font and Font Size selector fields. These let you select a font
that is used to display text in the List of Shelves and List of Publications.
Click the drop-down boxes to select from the list of available fonts and
sizes.

List of Shelves window
Shows a list of the bookshelves you can access.

Toolbar—List of Books and PDFs
Contains icons that provide shortcuts to common functions pertinent to
books and PDFs.

List of Publications window
Shows the list of the publications in the selected shelf. If the shelf has an
associated search index file, all books contained in the search index will
have a book icon that has a sheet of paper behind the book.

Notes:

1. You can sort the list of shelves or list of publications by clicking the column
heading. Clicking the same heading a second time reverses the order. For
example, click the Date heading in the List of Shelves to sort the shelves in date
order. The oldest shelves will be displayed at the top of the list. Click the Date
heading again to display the newest shelves at the top of the list.

2. You can change the order of the columns by dragging the column heading to
the left or right. For example, to display the Title before the Date, click and
hold the mouse button while the pointer is over the Title heading. Still while
holding down the mouse button, move the mouse to the left until the Title
column is displayed before the Date column.

© Copyright IBM Corp. 2000, 2007 13
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3. You can drag the horizontal divider up and down to adjust the relative size of
the List of Shelves and List of Publications.

@IBM Softcopy Reader: Shelf Organizer — IEIIEI
Menu bar File Edit “iew Search Active Directories Help

HIEBNEAPAE:: Font | Tahoma ~ | Font size |13 ~

List of Shelves

I Name I Dste I Title
H) 1 14BKED 02/11/05 17:00:20 /05 W1R7.0 TSO/E Bookshelf
List of M) 15F4pKS0 08/11/05 16:58:23 /0S5 W1R7.0 SDSF Bookshelf
Shelves A isFzPran 08/11/05 17:08:42 2/0S VIR7.0 ISFF BookShelf
ﬂl ISPZPM40 08/11/05 17:09:... |z/0S ¥1R7.0 ISPF PDF Extended Shelf
ﬂ ISF4BK S0 03/11/05 16:58.... |2f0S W1R7.0 SDSF PDF Extended Shelf
H||~rPovEK40 02/11/05 16:56:26 [z/05.2 W1R7.0 Cverview Bookshelf
TH] |20PBK3S2 03/12/05 11:30:... [2f0S ¥1R5.0 Infoprint Server POF Extended Shelf
HJ \csFeKkza0 03/12/05 23:48:25 |zf0S Y¥1R7.0 Cryptographic Services Bookshelf

.., ......................................................................................................................................

Shelf ISPZPM40 205 YV1RTY.0 ISFF BookShelf
D& Q<& m|a | | |
| | Date | Cocument | Mame

[E» z/05 W1R7.0 ISPF Dialog Developer's Guide [07/12/05 21:23:39 [SC34-4821-04 [ISPZDG40

[E» z/05 W1R7.0 ISFF DTL Guide 07/12/05 21:24:19 |SC34-4824-04 [ISPZDT40
List of [E» /05 W1R7.0 ISPF Edit and Edit Macros 07/12/05 21:33:35 |SC34-4820-04 [ISPZEM40
Books [E% z/05 w1R7.0 [SPF Messages and Codes 07/12/05 22:58:58 |SC34-4815-04 [ISPZMC40

and PDFs | [B#z/0S vIR7.0 ISPF Planning and Customizing 07/13/05 00:36:49 (GC34-4814-04 |ISPZPC40
[E22/0S VIR7.0 ISPF Reference Surmary  D7/11/05 21:07:10 SC34-4816-04 1SPZRS40
[E2/0S V1R7.0 ISPF SCLM Project Manager'... D7/11/05 21:00:36 SC34-4817-04 1SPZSC40

E»z/05 v1R7.0 ISPF Services Guide 07/13/05 03:03:39 5C34-4819-04 |ISPZSG40
[E>z/05 w1R7.0 ISPF SCLM Reference 07/12/053 03:42:31 SC34-4818-04 |ISPZSR40
[ z/05 w1R7.0 [SPF User's Guide Yol II 07/12/03 20,3802 |SC34-4823-04 [ISPZUZ40
[E2 /05 w1R7.0 ISPF User's Guide Yol I 07/12/03 03:34:14 \SC34-4822-04 |ISPZUG40

Figure 3. Shelf Organizer window

Menu Bar—Using the Menus

In addition to the functions that appear on the tool bar, there are several additional
features that are available through the menus. These are:

File
Create Shelf

Opens the Create Shelf window where you can enter the name and title of
the new shelf, select books or PDFs, and create a shelf.

Shelf Description
Displays information about the selected shelf.

Delete Shelves
Deletes the selected shelves from the list. Books and PDFs belonging to the
shelves are not deleted—only the shelf files.

Open Publication
Allows you to open a publication—a book in Book Reader, or a PDF using
a PDF reader. You can select which book or PDF to open from the books,
PDFs, shelves and shelf indexes directories that were defined when
Softcopy Reader was installed and any that were added since installation.

Close Closes the Shelf Organizer.
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Edit

Import Publication
Allows you to import books or PDFs from any location and include them
in the selected shelf. This is regardless of whether the new location path
exists in the user-defined configuration. Books can be imported into
bookshelves or extended shelves. PDFs can only be imported into extended
shelves.

Cut Publications
Cuts the selected books or PDFs from the current shelf. These books or
PDFs may be pasted into other shelves. Books can only be cut from
bookshelves, PDFs can only be cut from extended shelves.

Copy Publications
Copies the selected books or PDFs from the current shelf. These books or
PDFs may be pasted into other shelves. Books can only be copied from
bookshelves, PDFs can only be copied from extended shelves.

Paste Publications
Pastes the last cut or copied books into the currently selected bookshelf.

User Defined Directories
Opens the User Defined Directories for books, PDFs, shelves and Shelf
Indexes window. Books can only be imported into bookshelves, and PDFs
can only be imported into extended shelves.

View
Sort Shelves
Sorts the list of shelves by the selected column (Name, Date, or Title).

Another way to do this is to click on the column heading in the List of
Shelves.

Sort Publications
Sorts the list of books by the selected column (Name, Date, Title, or
Document Number). Another way to do this is to click on the column
heading in the List of Publications.

Filter Opens the filter windows for selecting and entering filter criteria for books
and PDFs or for shelves. For more information, see[“Using filters” on page

Refresh
Allows you to swap CD-ROMs in a CD-ROM drive and refresh the
directories, books, and bookshelves displayed on the Bookshelf Organizer
with those of the CD-ROM currently in the drive.

Search

Shelves
Opens the Search Shelves window to allow searching through all books on
the shelf.

Indexed Shelves (Quick Search)
Opens the Search Indexed Shelf window to allow searching through all
books on the bookshelf, or all PDFs indexed on the extended shelf.

Selected Books
Opens the Search Bookshelf window to allow searching through all the
books selected
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Active Directories
The term Active Directories refers to active User Defined Directories and specifies a
subset of the User Defined Directories to use when building the List of Shelves.

Edit User Defined Directories
Opens a window to allow changes to the User Defined Directories for
locating Books, PDFs, Shelves, and Shelf Indices.

Change Active Directories
Opens a window to allow changes to the Active Directories. Only the
directories selected in the Active Directories Window will be used in
building the List of Shelves.

Perform Auto Refresh
When selected, the Shelf Organizer performs an automatic refresh of the
List of Shelves if it detects a change. It will do a refresh if one of the
directories used to build the List of Shelves points to a storage device with
removable media, such as a CD-ROM, and the device has been changed
(for instance, a new CD has been inserted).

Help

Getting Started
Displays the online help screen.

User’s Guide
Opens the IBM Softcopy Reader User’s Guide

About Shelf Organizer
Opens the About Softcopy Reader window, which lists the current version,
service level, and driver level.

Toolbar—List of Shelves

This topic explains the icons in the List of Shelves toolbar.

Al G4 3

ﬂl Create Shelf

A dialog is opened asking if you want to create a bookshelf or extended shelf.

* Create a bookshelf—the Create Bookshelf window opens where you can enter
the name and title of the new bookshelf, and select the books that it will contain.

* Create an extended shelf—the Create Extended Shelf window opens where you
can enter the name and title of the new extended shelf, and select the PDFs and
books that it will contain.

Also available from the menu: File > Create Shelf.

Fy
|3l‘ Shelf Description
Displays information about the selected shelf.

Also available from the menu: File > Shelf Description.
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q Search Shelf

Opens the Search Shelf window to allow searching through all books on the
selected shelf.

Also available from the menu: Search > Shelf.

E Search Indexed Shelf (Quick Search)

Opens the Search Indexed Shelf window to allow searching through all books on
the selected bookshelf using the associated shelf index, if one exists, or searching
through all the PDFs which have been indexed on the selected extended shelf.

Also available from the menu: Search > Indexed Shelf .

'Pr' Delete Shelves

Deletes the selected shelves from the list. Books, Shelf indexes, or PDFs belonging
to the shelves are not deleted—only the shelf files.

Also available from the menu: File > Delete Shelves.

|
ﬁ Filter Shelves

Allows you to open and close the filter criteria field for filtering the list of shelves.
Entering a filter criteria in these fields will mask the shelves displayed in the list.

Filtering criteria are discussed in|“Using filters.”

Also available from the menu: View > Filter > Shelves.
Using filters

.
The shelf list or book list may be filtered by clicking on the .ﬁé [Filter Shelves]
button which opens the filter windows for selecting and entering filter criteria.
Select the column to filter from the drop-down list (Name, Date, Title or Document
Number for books or PDFs) and enter a regular expression in the adjacent field for
masking the entries in the table, then press Enter.

Valid expression operators are:

*  Multiple-character Wildcard

Matches any number of any characters. Examples:
xbook* in the Title field matches books, notebook, etc.

*/%/05% in the Date field matches shelves or books that were last updated in
2005.

? Single-character Wildcard

Matches any character in the specified location. Example: she?? Matches shelf,
shell, sheep, etc.

! NOT

Chapter 3. Using Shelf Organizer 17
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Excludes entries matching the criteria. This operator may be placed only at the
beginning of the regular expression. Example: !*book* matches all except
books, notebook, etc.

Toolbar—List of Books or PDFs

This topic explains the icons in the List of Books or PDFs toolbar.

oL |

G| e

[FE

Lu Open Publication
Opens the selected book in the Book Reader.

Also available from the menu: File > Open Book.

]
|3" Publication Description

Displays additional information about the selected book or PDFE.

aﬁ Search Selected Books

Opens the Search Bookshelf window to allow searching through the selected books
on the bookshelf.

Also available from the menu: Search > Selected Books.

,

i Import Publication

Allows you to import publications from any location and include them in the
selected shelf. Bookshelves can only hold books however. This is regardless of

whether the new location path exists in the user-defined configuration.

Also available from the menu: Edit > Import Publication.

E'Lf Cut

Cuts the selected publications from the current shelf. These publications may be
pasted into other shelves. Bookshelves can only hold books however.

Also available from the menu: Edit > Cut Publications.

I 1 Copy

Copies the selected publications from the current shelf. These publications may be
pasted into other shelves. Bookshelves can only hold books however.

Also available from the menu: Edit > Copy Publications.
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ﬁ Paste

Pastes the last cut or copied books into the currently selected shelf. Bookshelves
can only hold books however.

Also available from the menu: Edit > Paste Books.

|
ﬁ Filter Publication List

Allows you to open and close the filter criteria field for filtering the list of
publications. Entering filter criteria in these fields will mask the publications
displayed in the list. Filtering criteria are discussed in|“Using filters” on page 17)

Also available from the menu: View > Filter > Publications.

Starting Shelf Organizer

This topic explains how to start the Shelf Organizer from a command line in
Windows or Linux.

Note: If Shelf Organizer does not seem to start correctly, refer to |”Pr0b1ems|
[starting Shelf Organizer or Book Reader” on page 8.

Starting Shelf Organizer on Windows

1. Open a Command Prompt and navigate to the directory where Shelf Organizer
is installed. (Generally C:\Program Files\IBM\SCR\sys)

2. At the command prompt, type: hlcs.bat -d <system_path>
In the above example <systerm_path>= “C:\Program Files\IBM\SCR\sys”.

The following options are also available:

hlcs.bat options -d "system_path"
Where options include:
-i shelf_name Opens the specified bookshelf only
shelf _name Displays the specified bookshelf followed by
all bookshelves found by searching the

User Defined Directories.

-s -u shelf paths  Open bookshelf or shelves found in the locations specified
by the shelf paths and the user defined directories.

-s shelf _paths Open only the bookshelf or shelves found in the
path specified by shelf paths.

-b -u book_paths Look for books in the paths specified by book_paths
and the User Defined Directories.

-b  book_paths Look for books in the paths specified by book_paths
only.

-z ini_root_path Specifies the Tocation of configuration (.ini) files.

.ini files will be stored in a directory called
Application Data\IBM\SCR relative to ini_root_path.
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Notes:
1. All directory names must be absolute, not relative.

2. Directories in a path must be delimited by semicolons, and paths having
multiple directories should be enclosed in double quotes.

3. All flags must be surrounded by at least one blank character.
Examples:

With no options, launches Shelf Organizer:
hlcs.bat

With shelf option:
hlcs.bat c:\shelves\shelf.bks

java -jar hlcs -i c:\shelves\shelf.bks

With book options:
hlcs.bat -b -u "d:\books;c:\books"
java -jar hlcs -b "d:\books;c:\books"

With shelf options and book options:
hlcs.bat -s -u "d:\shelves;c:\shelves" -b -u "c:\books;a:\books"

With all of the options:

hlcs.bat -i c:\shelves\shelf.bks -s -u "d:\shelves;c:\shelves"
-b -u "c:\books;a:\books"

Starting Shelf Organizer on Linux

1. Open a Terminal Window and navigate to the directory where Shelf Organizer
is installed.

2. At the command prompt, type: hlcs.sh

The following options are also available:
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hlcs.sh options
Where options include:
-1 shelf_name Opens the specified bookshelf only.

shelf name Displays the specified bookshelf followed by
all bookshelves found by searching the
User Defined Directories.

-s -u shelf paths  Open bookshelf or shelves found in the locations
specified by the shelf paths and the user defined
directories.

-s shelf paths Open only the bookshelf or shelves found in the
locations specified by shelf paths.

-b -u book_paths Look for books in the Tocations specified by book paths
and the User Defined Directories.

-b  book_paths Look for books in the locations specified by book_paths
only.

-z ini_root_path Specifies the location of configuration (.ini) files.
.ini files will be stored in a directory called
Application Data/IBM/SCR relative to ini_root_path.

Notes:

1. All directory names must be absolute, not relative.

2. Directories in a path must be delimited by semicolons, and paths having
multiple directories should be enclosed in double quotes.

3. All flags must be surrounded by at least one blank character.
Examples:

With no options, launches Shelf Organizer:
hlcs.sh

With shelf option:
hlcs.sh /home/auser/shelves/shelf.bks

With book options:
hlcs.sh -b -u "/home/auser/books;/opt/scr/books"

With shelf options and book options:

hlcs.sh -s -u "/home/auser/shelves;/opt/scr/shelves"
-b -u "/home/auser/books;/opt/scr/books"

With all of the options:

hlcs.sh -i /opt/scr/shelves/shelf.bks -s -u "/home/auser/shelves;/opt/scr/shelves"
-b -u "/home/auser/books;/opt/scr/books"

Using the active directories, user defined directories and Auto Refresh

This section describes:

¢ How to add or remove items from the User Defined Directories which tell
Softcopy Reader where to look for Books, PDFs, Shelves, and Shelf Indexes.
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* How to use the Active Directories to control which Shelves are being displayed
in the List of Shelves.

¢ How Auto Refresh works and how to turn it on and off.

User defined directories

The “User Defined Directories” is a list of directories that Softcopy Reader uses to
locate Books, PDFs, Shelves and Shelf Indexes that are stored on your workstation
or accessible through a network. The User Defined Directories window can be
accessed from two places:

* Edit Menu: Edit > User Defined Directories

e Active Directories Menu: Active Directories > Add/Remove

-~

M| User Defined Directories for Publications, Shelves, and Shelf Indexes

F aths for Fublications, Shelves and Indexesfvailable Folders and Drives:

C:Abooks 4 =2 C

Lk oks b (== D

E:books dh =g

ET:‘:'“EE =1

P

CAProgram FileshBhWS CRAsys S Hi
¢ =3I
9 =X

Add | | Remowe Sawe | | Cancel

The User Defined Directories window allows you to add or remove directories. To
add a directory, in the right panel navigate to the directory you want to add, select
the directory, then click Add. The directory name you added will be listed in the
left panel. To remove a directory, in the left panel, select the directory to be
removed and click Remove. To save any changes click Save, or click Cancel to exit

without saving changes. After you click Save, the Shelf Organizer will refresh its
List of Bookshelves if necessary.

Active directories

The Active Directories window lists all the User Defined Directories that the Shelf
Organizer uses to locate Books, PDFs, Shelves, and Shelf Indexes on, or attached
to, your PC. It also lists any directories that may have been passed to the Shelf
Organizer as parameters from a Command Prompt. These directories are classified
as “Other Directories.” By selecting or clearing directories listed in the Active
Directories window you can control which directories are used when building the
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List of Shelves. The selected active directories pertain only to Shelves. The Shelf

Organizer will still use the complete list of directories when locating books, PDFs,

and shelf indexes.

The Active Directories window can be displayed by
Directories from the Active Directories menu.

The Active Directories window, shown in the following example, allows you to

selecting Change Active

select one or more, or all, of the directories containing shelves on your system. You
can use this window to look at specific directories to see which shelves are located

in the directory.

m.ﬁ.ctive Directories

User Defined Directories
[w] Cibooks
[w] CAShelves
[w] CAPrograrm FilesiBMSCR
[ EXBooks

[w] ENShelves

Other Dir ectories
[w] Dishelves [ &dd to User Defined Directories

[w] Dbooks [ Add to User Defined Directories

OK Cancel

Other Directories will not be remembered between uses of the Shelf Organizer. To
have the Shelf Organizer remember one or more of these directories, select the Add

to User Defined Directories check box for each directory you wish to save, and

click OK.
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mﬁmtive Directories

User Defined Directories
[w] Chbooks
[w] CAShelves
[w] CAPrograrm FilegiBMSCR
[w] E\Books

[w] EXShelves

Other Dir ectories
[w] DAshelves [#] Add to User Defined Directories
[w] Dbooks [¥] &dd to User Defined Directories
OK Cancel

Open the Active Directories window again and you will see that the selected
directories were added to the User Defined Directories.

mﬁmtive Directories

User Defined Directories
[w] Cibooks
[w] CAShelves
[w] CAPrograrm FilesUBMESCR
[w] E:\Books
[w] EiShelves
[w] DAshelves

[w] Dbooks

OK Cancel

On startup, the default is to make all the directories active, therefore they will all
be selected. If you clear all but C:\Shelves from the Active Directories window and
click OK, as shown:
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mﬁ.ctive Directones E

[] Chbooks

[w] CAShelves

[ ] EXBooks
[] EXShelves
[ Dishelves

[] Dibooks

User Defined Directories

[] CAPrograrm FilegtBMSCR

0K

Cancel

... the Shelf Organizer will show only Shelves for the "C:\Shelves” directory.

The advantages of using the Active Directories to

gether with Auto Refresh can be

seen in [‘Auto Refresh—Windows platform only.”

Auto Refresh—Windows platform only

If Auto Refresh is turned on, the Shelf Organizer will automatically rebuild the List
of Bookshelves when removable media, such as a CD, is removed or inserted in a

CD-ROM drive.

To ensure Auto Refresh works properly, be sure that:

e Perform Auto Refresh is selected in the Active Directories Menu.

* The User Defined Directories has a path that is on a storage device with
removable media, such as a CD-ROM drive, or such a path is passed to the Shelf
Organizer as a command line parameter. The CD should be one that has Books,
PDFs, Shelves, or Shelf Indexes.

* In the Active Directories Window, the directory on the storage device with the
removable media, such as a CD-ROM drive, is selected.

In this example, the CD-ROM drive is represented by “D:\”. The "D:\Shelves” and
"D:\Books” were added to the User Defined Directories as described in

idefined directories” on page 22] These were then made the only active directories

in the Active Directories window. You can have other directories selected as
well—these Active Directories are limited to the CD-ROM drive to simplify the

example.
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mhctive Directones E

User Defined Directories
[] Chbooks
[] CAShelves
[] CAPrograrm FileglBMSCR
[] EXBooks
[] EXShelves
[w] Dishelves

[w] Dbooks

OK Cancel

Click OK, and you will see the following window displayed.

EIBM Softcopy Reader: Shelf Organizer Y [m]

File Edit Miews Search  Active Directories  Help

FlE LN A Font | Tahoma ~ | Font Size [13 ~
Lizt of Shelves

L Name l Date I Tile |

A |spoR TR 092404 10:26:23 [BM Online Library Reference Bookshelf -

M |~DMDSHOS 11/05/01 14:21:15 |GDDM 3.2 Bookshelf

M |soPRK3S1 04/28/04 15:43:03 2/0S Y1R5.0 Infoprint Server Bookshelf

M |asmsHoz0 03/02/04 22:56:28 High Level Assermbler for MYS & WM & WSE V1RSSO ..

M BDTZEKZ0 07/20/04 12:42:34 |z/05 Y1RA.0 BDT Bookshelf

M cRCBS150 07/26/04 19:11:50 z/0S Y1RA6.0 CfC++ Bookshelf

M ceRODzEKS0 07/20/04 07:47:12 |2/0S W1RA.0 HZD Bookshelf

M |cEEZBKS1 01727705 07:19:00 |z/05 Y1R6.0 Language Environment Bookshelf

M [cimzek21 06/26/03 06:56:52 |z/05 Y1R4.0 Managed System Infrastructure for Se...

M csFeRzS1 01/19/05 14:13:32 |z/0S Y1R6.0 Cryptographic Services Bookshelf -

Shelf ABORWTZR : IBM Online Library Reference Bookshelf

j@@@@ | ]| 4 ¥

Title || Date || Dacument || Marne
[E:[In=talling, Managing, and Using the Cnline L...09/24/04 11:01:15 [GC31-8311-31  [ABOINOIL
Ea 05/390 W2R4.0 BookManager Hints and Tips |10/21/97 15:07:09 |[GC28-1987-02 |EO0Z11102
[E:[IBr SoftCopy Librarian: User's Guide 07/21/04 11:34:08 GC23-3414-14 |EBRSCL1Y
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In this example, the CD-ROM drive contains one of the z/OS Collection Kit CDs. If
you remove the CD, the Shelf Organizer will refresh the List of Shelves. Because
the only active directories that are selected point to the CD-ROM, the list of
shelves will be empty.
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If you put in a different z/OS Collection Kit CD, Shelf Organizer again refreshes
the List of Shelves listing the new set of shelves and books as shown in the
following.
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This can be very convenient when viewing Books on many different CD-ROMs or
other storage devices with removable media. To turn off Auto Refresh simply clear
the Perform Auto Refresh check box in the Active Directories Menu.

Opening a shelf

This section shows how to start Shelf Organizer, view the list of shelves on your
system, and view the books or PDFs within the shelf. If the bookshelf has an
associated search index file, all books contained in the search index will have a
book icon that has a sheet of paper behind the book.

When the Shelf Organizer is started, the IBM Softcopy Reader List of Shelves
window opens and lists all of the shelves on your system that:

* You specified during the IBM Softcopy Reader installation, or changed later

* You added to the User Defined Directories for Books, PDFs, Shelves and Shelf
Indexes since installation

Note: You must have all CD-ROMs you plan to use, such as the IBM Online
Library CD-ROMs, in the CD-ROM drives before starting the Shelf
Organizer.
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Figure 4. List of Shelves window

Starting Shelf Organizer

1. Insert the IBM Online Library CD-ROM into the CD-ROM drive.

Note: If you are using multiple CD-ROM drives, be sure you put all of the
Online Library CD-ROMs you plan to use in the drives before starting

Book Reader or Shelf Organizer to open the Online Library.

On the Windows Desktop start the Shelf Organizer by double-clicking the Shelf
Organizer desktop icon, or click the Start button and do the following:

* Select the Programs option.
* Select IBM Softcopy Reader.
* In the Softcopy Reader group, select the icon for Shelf Organizer.

The IBM Softcopy Reader List of Shelves window is displayed (see .

The List of Shelves subwindow shows all of the shelves that you have access to
on your system. This list of shelves contains all those found on the directory
paths configured into your user-defined directories.
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Notes:

a.

The icon to the left of the Name you selected will change to show an open
shelf.

You can change the order of how the shelves are listed (alphabetically or
chronologically) by clicking on the Name, Date, and Title tabs of the
window.

Selecting a shelf and listing the books or PDFs

From the List of Shelves subwindow, highlight the shelf that contains the book or
PDF you want to open by clicking on the shelf name. The Shelf subwindow
(below) will display the name of the Shelf you selected and list all of the books. If
the bookshelf has an associated search index file, all books contained in the search
index will have a book icon that has a sheet of paper behind the book.
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You can change the order of how the books are listed (alphabetically or
chronologically) by clicking on the Name, Date, Title, and Document tabs of the
window.

Opening a publication from the shelf
From the Shelf subwindow, double-click a book or PDF.

* For books, this will open the Book Reader window and display the book you
selected.

* For PDFs, this will launch the user-specified PDF reader.

Getting a description of a shelf
You can see a description of the shelf by clicking File, then Shelf Description.
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M Shelf Description

Shelf Title Installing, Managing, and Using the Online Library
Shelf Name INSTALL

Shelf Path E:SHELVES!install.hks

Shelf Date 05/06/02 14:08:31

Shelf Files 1

Shelf Index Hame INSTALL

Shelf Index Dictionary Name EIJENGL

Shelf Index Update Timestamp 05/06/02 14:08:31

Closing a shelf and Shelf Organizer
To close the shelf and Shelf Organizer, click File, then click Close.

Creating a shelf

These are the steps involved in creating a new Bookshelf:

1. Determine the books you want to include in the new bookshelf. These books
can be from:

* One or more existing bookshelves on your system

* New books that are not in any of your current bookshelves

Note: All of the books that are currently on your system (that are in
user-defined directories you specified during the IBM Softcopy Reader
installation and in any new user-defined directories created since
installation) can be listed in the Create Bookshelf window.

2. Determine a title or description for the new bookshelf - optional, but
recommended

3. Determine a bookshelf name you want to assign to the new bookshelf -
required

4. Determine if an index file has already been created for this bookshelf - optional

5. Determine where you want to store the new bookshelf. Once you create the
bookshelf it must be saved to a drive with write access, such as the C: drive on
your PC.

6. Start Shelf Organizer
7. Create the new bookshelf

Creating an Extended Shelf
These are the steps involved in creating a new Extended Shelf:

1. Determine the PDFs and books you want to include in the new shelf. These
can be from:

* One or more existing bookshelves on your system
* New PDFs and books that are not in any of your current bookshelves
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Note: All of the PDFs that are currently on your system (that are in
user-defined directories you specified during the IBM Softcopy Reader
installation and in any new user-defined directories created since
installation) can be listed in the Create Shelf window.

2. Determine a title (required)—1 to 255 characters with at least one
non-whitespace character

3. Determine a shelf name you want to assign to the new shelf (required)

4. Determine if an index file has already been created for this shelf (optional)

5. Determine where you want to store the new shelf. Once you create the shelf it

must be saved to a drive with write access, such as the C: drive on your PC.

6. Start Shelf Organizer
7. Create the new shelf

Starting Shelf Organizer

1. On the Windows Desktop, click the Start button.

2. Select the Programs option.
3. Select IBM Softcopy Reader.
4. In the Softcopy Reader group, select the icon for Shelf Organizer.

The IBM Softcopy Reader List of Shelves window (below) will open.

EIBM Softcopy Reader: Shelf Organizer

File Edit

Wiew Search

Active Directories

Help

=101 x|

A EQ

&

K5

Font | Tahoma

v | FontSize (13 ~

List of Shelves

|

Mame

l Dite

Title

TH[EECZRKSD
H][eDTZEK4D
M 14T2BKS0

THHTTPDGTO
M| soPRKaS2
THl[ceCxs110
i [1sPzPra4n
TH| [sPzPr40
Tif|[ERRZBKS0
Ml |\cBCxs110

05/11,/05 17:30:39
05/11,/05 17:41:26
02/11,/05 16:51:27
02/11,/05 17:31:48
09/11,/05 17:43:01
08/11,/05 17:02:37
08/11,/05 17:08:42
05/11,/05 17:09:03
02/11,/05 17:06:14
0E/11,/05 17:02:31

205 Y1R7.0 HCM PDF Extended Shelf
Z/05 Y1R7.0 BDT Bookshelf

z/05 Y1R7.0 JES3 Bookshelf

205 W1R7.0 IBM HTTF Server PDF Extended Shelf
z/05 %1RS.0 Infoprint Server Bookshelf
z/05 %1R7.0 Run-Time Library Extensions POF Ext...
205 Y1R7.0 ISPF BookShelf

205 Y1R7.0 ISPF PDF Extended Shelf
205 Y1R7.0 RMF POF Extended Shelf
z{05 %1R7.0 Run-Time Library Extensions Bookshelf

| »

Shelf ISPZPM40: 205 YV1R7.015PF BEookShelf

o ||| 531

i3

|

Title

l Date

|| Document

|| Mame

[ z/05 w1R7.0 ISPF Dialog Developer's Guide

E>[z/0s v1R7.0 ISPF DTL Guide
E» z/05 V1R7.0 ISPF Edit and Edit Macros
Ea[z/0S v1R7.0 ISPF Messages and Codes

Ex[z/0S w1R7.0 ISPF Planning and Customizing

E>[z/0S w1R7.0 ISPF Reference Summary

B2 z/05 W1R7.0 [SPF SCLM Project Manager's ...

E»|z/05 W1R7.0 ISPF Services Guide
E» =05 V1R7.0 ISPF SCLM Reference
E»z/05 V1R7.0 ISPF User's Guide Yol 11
Ex|z/05 w1R7.0 ISPF User's Guide vol I

07/12/05 21:23:39
07/12/05 21:24:19
07/12/05 21:33:35
07/12/05 22:58:58
07/13/05 00:36:49
07/11,/05 21:07:10
07/11/05 21:09:36
07/13/05 03:03:39
07/12/05 03:42:31
07/12/05 20:35:02
07/12/05 035414

SC34-4321-04
SC34-4324-04
SC34-4820-04
SC34-4815-04
EC34-4314-04
SC34-4316-04
SC34-4317-04
SC34-4319-04
SC34-4818-04
SC34-4823-04
SC34-4322-04

[SPZD40
[SFZ0T40
[SPZEM40
[SPZMAC40
[SPZPC40
[SFZRS40
[SPZSC40
[SPE5G40
[SPZSR40
[SPZL240
[SFPZLIG40

Chapter 3. Using Shelf Organizer

31



Creating a new shelf

From the Shelf Organizer main window, select File > Create Shelf.

Select the type of shelf you want to create:
1. Book shelf (containing only books)
2. Extended shelf (can contain PDFs as well as books)

Creating a new book shelf

In this procedure you will create a new bookshelf and store it on a directory that
you specify. This directory must have write permission.

1. From the “Select the type of shelf to create” window, select Book Shelf to open
the Create Bookshelf window.

Create Booksheli El

Boaokshelf Title: Inciude Books From Locations:
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2. Under Bookshelf Title [1], enter a description or title of your new bookshelf -
optional, but recommended.

3. Enter a Bookshelf Name [2]. This is the name stored internally in the
bookshelf. A bookshelf name is required (limited to 8 characters).

4. Under Index Name [3], enter the name of any pre-built bookshelf index that
was built for this bookshelf (e.g. if for a shelf called “mybooks” the index file
name is called mybooks.bki, the Index Name should be specified as
“mybooks” - an Index Name is optional (limited to 8 characters)

5. From the Include Books From Locations window [4] you will see a list of user
specified paths and directories, and the number of books in each directory.
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Check the boxes next to the path names on your system, or attached to your
system via a network, that include books you want to include in the bookshelf
you are creating.

All of the books from the directories you selected will be listed in the Include
Selected Books window [5].

6. From the Include Selected Books window, select the books you want to
include in your new bookshelf:

* Single book: click on the book

* Multiple books in various places: hold down the Ctrl key, then click each
book wanted

¢ Multiple books in sequence: hold down the Shift key, then click the first
book and the last book in the sequence

* All books: press the Ctrl + A keys
7. Click OK [6].
The Save Bookshelf window (below) will open.
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O help -
Ale nariec ?|rnrbuuks | | Sauo
hles of tye | Bookdannger Bookshehes - | Cancel

8. Verify the file name [7]

9. If the directory in which you want to save the new bookshelf is listed,
highlight the directory name [8] and then click Save [9]. This directory must
have write permission.

If the directory you want is not listed, you must go to the correct drive on
your system and locate the directory - see next step.

10. In the Look in: window, click the down arrow and select the drive that
contains the directory where you want to store the new bookshelf.

11. When you locate the proper directory, highlight it and then click Save.

Create a new extended shelf
In this procedure you will create a new extended shelf and store it on a directory
that you specify. This directory must have write permission.

1. From the “Select the type of shelf to create” window, select Extended Shelf,
and the following Create Extended Shelf window will open.
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Under Shelf Title [1], enter a description or title of your new shelf - required,
(up to 255 characters).

Enter a Shelf Name [2]. This is the name stored internally in the shelf. A shelf
name is required (limited to 8 characters).

Under Shelf Author [3], enter the author’s name - optional (limited to 8
characters)

Under Shelf Index Name [4], enter the pre-built shelf index name (limited to 8
characters)

Under Shelf Index Dictionary [5], select the language code of the dictionary
used with the pre-built shelf index. Example: EIJENGL is the US English
dictionary.

Under Shelf Index Update Timestamp [6], enter the time stamp when the
pre-built shelf index was updated, in this format: mm/dd/yy hh:mm:ss

From the Include Publications From Locations window [7] you will see a list
of user specified paths and directories, and the number of publications in each
directory. Check the boxes next to the path names on your system, or attached
to your system via a network, that include PDFs and books you want to
include in the shelf you are creating.

All of the PDFs and books from the directories you selected will be listed in
the Include Selected Publications window [8].

From the Include Selected Publications window, select the PDFs and books
you want to include in your new shelf:

* Single publication: click on the file

* Multiple publications in various places: hold down the Ctrl key, then click
each of the files wanted

* Multiple publications in sequence: hold down the Shift key, then click the
first file and the last file in the sequence

IBM Softcopy Reader User’s Guide



 All publications: press the Ctrl + A keys
10. Click OK [9].
The Save Extended Shelf window (below) will open.

,
MlJ save Extended Shelf

LookIn: |__| Administrator b £

Desktop et
ALl E

| | Local Settings

|| My Documents £

|| NetHood |
|| PrintHood

" 1Recent
12

0
File Name:  |MYPDFS | "~ | open

1]

Files of Type: Extended Shelfi.xks) i Cancel

11. Verify the file name [10]

12. If the directory in which you want to save the new shelf is listed, highlight
the directory name [11] and then click Open [12]. This directory must have
write permission.

If the directory you want is not listed, open the correct drive on your system
and locate the directory - see the next step.

13. In the Look in: window, click the down arrow [13] and select the drive [14]
which contains the directory where you want to store the new shelf.

14. When you locate the proper directory, highlight it and then click Save.
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Importing PDF and book files into a shelf

This section shows you how to import PDF and book files into an extended shelf.

In this procedure, you will see how to select publications from various locations
(such as: internal hard disk drives, external drives on a network, or other storage
devices attached to your system) and put them into an extended shelf.

1. Start the Shelf Organizer program.

2. From the List of Shelves, select a shelf in which you wish to import files. You
can also create a new shelf in which to import the publications.

Select the shelf by clicking on it, as shown in the following example.

List of Sheles

l Narme I Diste I Title |
H[15F4BKS0 08/11/05 16:58:23 |2/0S Y1R7.0 SOSF Bookshelf -
ﬂl [SF4BKS0 08/11/05 16:58:28 |2/0S Y1R7.0 SDSF POF Extended Shelf ]
M [1cHzRKED 08/12/05 23:40:50 |2/0S W1R7.0 Security Server and Integrated ...

TH] [cHZBRED 08/13,/05 05:36:24 |2/0S %1R7.0 Security Server and Integrated ...

B 14pKE0 0S/11,05 17:00:20 |z/0S Y1R7.0 TSO/E Bookshelf

ﬁl [K14BEE0 08/12/05 11:57:08 &/0S Y1R7.0 TSO/E POF Extended Shelf [z
] BPxZSHAED 08/12/05 23:45:16 |2/05 W1R7.0 UNIX System Services Bookshelf |«

Shelf [kKJ4BKED : 205 VIRY.0 TSOE PDF Extended Shelf

@@Q%@&?Hﬁﬁﬁ

|| |
| Impart Fublication | Date ” Document ” Neme |
g?‘“ /OS5 Y1R1.0 TSO 06,2705 22:21:01 SAS2-7780-00 [K14A100 I:

3. On the Shelf Toolbar (lower toolbar in the IBM Softcopy Reader List of Shelves
window), click the Import Publication icon.

The Import Publications window will open.
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[l import Publications |

Include Publications From Locations; 1
D Cebooks (365 public ations)
D Dishelves (0 publications)
D AaBooks 1149492 publications)
D A5 helves (O publications)
D CAFragram FilesilBh\Softcopy Readensys (0 publications)
[¥] 5507 publications)

Include Selected Publications (Columns with a ™ are required):

;E:‘ Io* | File Mame* | File Type | Mame* | Title* Upd
I5a |SPFDOG Soispzogd podf  |POF File ISPZO40 ISPF Dialog Desy Guide: 0vm2
@!3‘“ SoMispzotd4] pdf  |PDF File ISPZDT40 a7
ﬁ‘“ [SPFPAC  SiMizspzpcdl pdf |PDF File ISPZPC40 I=ZPF Planning & Cust 073
oy Sispzr=40 pdf  PODF File ISPZRS40 Wk
@!3‘“ 3 SMizpzegdld pdf  |PDF File ISP 25340 4 o3
@!3‘“ ISPFSYG Sivizpzerd0.pdf  PDF File ISPE=R40 |SPF Services o7 3
o SWizpzugdl podf POF File  ISPZUGE0 07 3

4. Under Include Publications From Locations [1], select the locations from where
you wish to select PDFs and books.

5. Under Include Selected Publications [2], select the publications you wish to
import. To select a publication, click on its file name. Hold down your Ctrl key
to select multiple files.

6. There must be an ID and Title for each publication you want to import. Enter
an ID [3] and Title [4] for each publication, then press Enter.

7. Click OK. The publications will now be displayed in the extended shelf that
you selected in step 2, as shown in the following example.

Chapter 3. Using Shelf Organizer 37



38

E]IBM Softcopy Reader: Shelf Organizer - |EI|5|
File Edit “iew Search Active Directoriez  Help

iﬂ|@;|g|@ gg|%h Font | Tahoma ~ | Font Size (13 +
I

List of Shelves
Narme I Diste Title |

H[15F4BKS0 08/11/05 16:58:23 |2/0S Y1R7.0 SDSF Bookshelf =
TH] 1SF4BKS0 08/11/05 16:58:28 |2/0S Y1R7.0 SOSF POF Extended Shelf

M 1cHzRKED 08/12/05 23:40:50 |2/0S W1R7.0 Security Server and Integrated ...

TH] [cHZBRED 08/13,/05 05:36:24 |2/0S %1R7.0 Security Server and Integrated ...

B 14pKE0 0E/11,05 17:00:20 |z/0S Y1R7.0 TSO/E Bookshelf

T IkI4BKE0 08/12/05 11:57:08 z/0S Y1R7.0 TSO/E POF Extended Shelf B
M BPxZSHAED 08/12/05 23:45:16 |2/0S W1R7.0 UNIX System Services Bookshelf |«

Shelf [kKJ4BKED : 205 VIRY.0 TSOE PDF Extended Shelf

M| B Q||| K| [0]| )| 8¢

J| Title: || Drate || Documet || Marme

g?*ﬂ ISPF Dialog Dev Guide ] 07/12/05 08:35:59 [SPFDDG ISPZDG40 = |
g!h ISPF F'Iar'lning & Cust + 071305 07:52:43 ISPFPAC ISPZPC40
}ﬂ ISPF Services _ 071305 08:53:42 ISPFSYG ISPLSR40

@Pﬂ z/05 Y1R 1.0 TSO/E administration 06/27/05 22:21:.., [SAZ2-77B0-00 IK14A4100

,9?* /05 V1R 1.0 TSO/E Primer 06/27,/05 22:24:,,, SAZ2-77E7-00 [KI14P100

}*ﬂ 205 Y1R2.0 TSO/E REXY User's Gu,,, 06/27,05 22:22:.., [SAZ2-7791-01 [K14C310 =
}ﬂ 205 Y 1R3.0 TSO/E General Inform... [06/27/05 22:21:.., SAZ2-7734-02 [KI4B320

@Pﬂ /05 Y1R3.0 TSO/E System Progra... 062705 22:23:.., |SAZ2-7793-02 [K14C420

@Pf' 205 Y1R5.0 TSO,E Programming S... 06/27/05 22:22:.., |SAZ2-7729-04 [IKI4R740

g?*ﬂ /05 Y1R5.0 TSO/E User's Guide 06/27/05 22:22:.., [SAZ2-7794-02 [K14C220 =]

Viewing and modifying PDF file details

This section shows you how to view the details of your PDF files, and how to
customize the document properties of each PDF file.

How to View the Details of a PDF File

In the Import Publications window, right-click on the PDF file you wish to
view details. A Properties box will pop up.
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E Import Publications B3

Include PDF's From Locations:
[v] Cobooks (4 PDF'S
[ Dofmeb-test (0 PDF'S)
D C:AFrogram FilesdBWESCRSys (0 PDF'S)
[ cofUser (1 POF'S

Include Selected PDF's (Colurmns with a * are required):

}_" ID* | Filemame* | FileType | Name* Title* | ug
3 DR Ccon... PDF File DOCCann Document Connection 12
}*ﬂ SERWICE restvice.... |PDF File Service Service 10,
,}ﬂ SPECIAL CbooksSpecial.... PDF File Special 05,
}*ﬂ ZOsEMODEL ook I OSmod. .. |PDF File ZoEmodel IS Madels 12

2. Click Properties. The following window opens, showing details of the PDF file.

& Document Properties Eq

Document Information:

1D IDOCCONN |
Type PDF File

*Name |DDCcnnn |
*Title Docurment Connectio

*Update Timestamp 1210402 13:58:43

Update Comment All books

Subject |Dncumentatinn |
Kevwords Docs

Author |, Smith |

Exzpiration Timestamp |IIIEIE 572004 |

URI

] Cancel Help
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Customizing the document properties of your PDF files

You can create a detailed description of each of your PDF files. when you view the
list of PDF files, you will see a number of columns in which you can fill in with
information about the files. Following is a list of information fields that you can
customize:

ID (required)
An identifier unique within the XKS which starts with a letter or an
underscore and contains one or more letters, numbers, periods, or dashes.

Type PDF File (default)

Name (required)
Name within the shelf. Must be 1 to 8 characters starting with a letter. The
remaining characters can be a combination of letters, numbers, and dashes.

Title (required)
1-255 characters

Update Timestamp
Timestamp publication was last updated following this format:
MM/dd/yy HH:mm:ss

Update Comment
Whatever information you want to put in this field

Subject
Whatever information you want to put in this field

Keywords
List of blank-separated, author-provided, "Find Book” searchable
keywords.

Author
Whatever information you want to put in this field

Expiration Timestamp
A date that you choose as an expiration date. This is not an automated
field and nothing will happen to the document on that date. The field uses
this format: MM /dd/yy HH:mm:ss

URI  Fully qualified location of publication. Usually takes form of file URL. Use
of this field is neither portable, nor encouraged.

Searching multiple documents in a shelf (or across multiple shelves)

40

This section describes how to:

* Initiate a search (regular search) for specific information (word or words) across
all books in a single shelf (or across multiple shelves at the same time)

* Initiate an indexed search (quick search) for specific information (word or
words) across all books in a single bookshelf or all PDFs indexed on an
extended shelf (or across multiple shelves at the same time)

* Initiate a search (regular search) for specific infomation (word or words) across
books for selected documents in a shelf

* Customize the way books are searched and the results displayed:
— Find an exact match (case sensitive)
— Find an exact match (not case sensitive)

— Fuzzy match

Use Boolean operators in the search
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— Specify what material in the book to search (titles, text, and indexed words)

— List the results in order of importance (or in page sequence)

Extended Shelf (XKS) Search - Document Handling

Starting with Softcopy Reader V3.6, this is the way various documents are handled
by XKS search:

1. Quick Search (Indexed Search) of an Extended Shelf (XKS) having a shelf index
(BKI) will search the shelf index (BKI) for all documents on the shelf (no
addenda document handling for Quick Searching an Extended Shelf (XKS).

* For PDF document instances on the shelf, PDF search hits are listed (any
PDFs not found, or whose document is not in the shelf index (BKI) , will be
identified)

* For BookManager Book document instances on the shelf, corresponding PDF

search hits are listed (any PDFs not found, or whose document is not in the
shelf index (BKI), will be identified.

2. Quick Search (Indexed Search) of an Extended Shelf (XKS) without shelf index
(BKI) is not allowed. (no addenda document handling is performed for Quick
Searching an Extended Shelf (XKS).

3. Regular Search (Unindexed Search) of an Extended Shelf (XKS), with or
without a shelf index (BKI) will search each document on the shelf individually.

* For PDF document instances on the shelf, only corresponding BookManager
Books are searched and listed as hits (PDFs without a corresponding
BookManager Book are identified)

¢ For BookManager Book instances on the shelf, actual BookManager Books
are searched and listed as hits

4. Regular Search (Unindexed Search) of selected documents in an Extended Shelf
(XKS) will search each document individually.

* For selected PDF document instances, only corresponding BookManager
Books are searched and listed as hits (PDFs without a corresponding
BookManager Book are identified)

* For selected BookManager Book document instances, actual BookManager
Books are searched and listed as hits

What if search can not find a document or documents (book
or PDF files)

If the search cannot find a document or documents in the shelf, you will get a
message indicating the document (documents) listed in the message could not be
found. This could be as a result of:

¢ The path that you defined for the document (documents) is not valid
* A CD-ROM containing the documents is not in inserted in the CD-ROM drive
* A network connection, to documents at a remote location, is broken

* Missing documents due to modifications to existing shelves or creating your
own custom shelves by adding and deleting documents

Searching a shelf (or multiple shelves) using the regular
search function—all books

Entering a new Search request

You can start the search process from either the Menu Bar or the toolbar:
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1. Select a shelf you want to search from the IBM Softcopy Reader List of Shelves
window.

Multiple shelves—You can select multiple shelves for the search. Hold down
the Ctrl key, and select (click on) all of the shelves you want to search.

2. Start the search process:
From the Menu Bar: Click Search, then click Shelves.

Or, from the Toolbar: Click El?-' [Search]
The Search Shelves window is displayed.

3. Enter one or more search words in the Search Request window. The example
below shows “workstation” as the search request. You can customize the search
in several ways—see [“Customizing the search (regular search only)” on page|

x|
Q| Hd @& 2 &

Search Reguest:

|wu:|rk5tati|:| h

Search Reszet Cloze Helg

Buttons on the Search Shelves window:

Search Start the search process.

Reset Clears the Search Request window and returns the options to
their default state.

Close Closes the search window

Help Displays the help screen

4. Click Search to start the search.

The results of the search are displayed (below) in the lower two panes of the
Search Shelves window: In this example.

* 11 Books with Hits Found—this is the number of books on the shelf (shelves)
that contained the search word “workstation.” You can scroll down this list
to see the Name (file name) and Title of each book. You can highlight any
book in the list (click on it) and see which topics in the book contain search
results in the lower window.

* 5 Search Results for Book ISPZEM40—this is the number of topics in the
book where the word “workstation” was found.
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[Tl|search shelves

Q| Bd EE &

Search Reguest:

|vvnrkstaﬁun

Search Reset Close Help

11 Books with Hits Found:

Mame Title
& ISPZSR40 z/OS VRY O ISPF SCLM Reference
& ISPZSGA0 ZIOS W1RT D IZPF Services Guide
&2 [ISPZEM4D Zi0S NRY O IZPF Edit snd Edit Macros
& ISPZDG40 /05 VMRYT O ISPF Dislog Developer's Guide
& ISPZUGAD ZIOS VRT O IZPF User's Guide Yol |

5 Search Resultz For Book ISP ZEM40

1.1.3.1 .2 Edit Ertry Panel Fields

1.1.2.1 Distributed Editing

FROMT_1 .4 Using Look&t to look up message explanations
1.1.3.1.1 Edit Ertry Panel Action Bar

FROMT _3.2.3.2 Uilties &ction Bar Choice

5. Double-click any of the search results listed for the selected book, and:

¢ The Book Reader program will open (see below)
* The book with the search results will be displayed

* A Search Book window will be open on the Book Reader window showing

all of the search results for that book
+ All words matching the search are highlighted in red.
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% X\ Books\ ISPZEM40.boo: z/0S ¥1R 7.0 ISPF Edit and Edit Mal

Fila Edit View Navigate Search

Motes Help

HEFIEENE

B

SNOEEIECIENE

Font E

FROMT_3 The I5PF User Interface
1.0 Part 1. The ISPF Editar
# 1.1 Chapter 1. Introducing the |
1.1.1What is ISPF?
= & 1.1.2 What the |5PF Editor O
1.1.2.1 Distributed Editing
< & 1.1.3 How to Use the |5PF Ed
4+ & 1.1.4 Edit Commands
4 & 1.1.5 Edit Macros
# 1.2 Chapter 2, Controlling the E
4 & 1.2.1%What is an Edit Profile?
4+ & 1.2.2 Edit Modes
% & 1.2.3 Flagged Lines
1.2.4 Edit Boundaries
1.2.5 Initial Macros
1.2.6 Application-Wide Macrog
ap & 1.2.7 Statistics for PDS Memb
1.2.8 Yersion and Modificatio
4+ & 1.2.9 Sequence Numbers
¢ & 1.2.10 Enhanced and Languag
1.2.11 Edit Recovery
# 1.3 Chapter 3. Managing Data
1.3.1 Creating and Replacing O
1.3.2 Copying and Moving Dat
4k & 1.3.3 Shifting Data

N

-

'4]= & 1.3.4 Flndmg, Seekmg, Chang

1

X

editing,

1.1.2.7 Distributed Editing

I5PF enables wou to edit host data on a workstation, and workstation

#. Search Book: X:'Books\ISPZEM40.bog

Qo wE B 2 J

Search Request:

|warkstation

| workstation hd |

| Search || Reset || Cloze || Help |

Search Results:

1.1.3.1.2 Edit Entry Pane[,\@ields

1.1.2.1 Distribwted Editing

FROMNT _1.4 Using LookAt to look up message explanatiol
1.1.3.1.1 Edit Entry Panel Action Bar

FROMT_3.2.3.2 WKilities Action Bar Choice

<]
5 Results.

ator, is a wo
em. After set
jons and sen
ost or with h

e z/05 ISPF i

Searching an indexed shelf (or multiple shelves) using the
Quick Search function—all documents

Entering a New Search request

An Indexed Shelf Search (Quick Search) is a high speed search of a shelf using a
specially created search index file (BKI). An Indexed Shelf Search is only
performed if an index file is associated with the Shelf and is located within one of
the user-defined directories. In the List of Publications for an Indexed Shelf, books
that have been built into the Search Index are designated with a special indexed

book icon:

Ea

You can start the search process from either the Menu Bar or the toolbar:
1. Select a shelf you want to search from the IBM Softcopy Reader List of Shelves

window.

Multiple shelves—You can select multiple shelves for the search. Hold down
the Ctrl key, and select (click on) all the shelves you want to search. Not all
Selected Shelves need to be indexed, however, extended shelves must be

indexed for Quick Search.
2. Start the search process:

From the Menu Bar: Click Search, then click Indexed Shelves.

Or, from the Toolbar: Click E [Quick]
The Search Indexed Shelves window is displayed.
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3. Enter one or more search words in the Search Request window. The example
below shows “workstation” as the search request. You can perform an indexed
search using boolean operators by selecting the Advanced Search button;
however, unlike regular searches of unindexed Shelves, you cannot customize
the default values of “Fuzzy Search,” “List Results in order of Importance,”
“Search Topic Titles,” “Search Topic Text,” and “Search Indexed Words” when
performing an Indexed Shelf Search (Quick Search).

x
&l (&I [1 ][] [=][n] L] [=][=]

Search Request:

|wnrk5tatinn

Search Reset Cloze Help

Buttons on the Search Shelves window:

Search Start the search process.

Reset Clears the Search Request window and returns the options to
their default state.

Close Closes the search window

Help Displays the help screen

4. Click Search to start the search.

If the shelf being searched is a bookshelf, results of the search are displayed
(below) in the lower two panes of the Search Indexed Shelves window: In this
example.

* 11 Books with Hits Found—this is the number of books in the shelf (shelves)
that contained the search word “workstation”. You can scroll down this list
to see the Name (file name) and Title of each book. You can highlight any
book in the list (click on it) and see which topics in the book contain search
results in the lower window.

* 18 Search Results for Book ISPZPC40—this is the number of topics in the
book where the word “workstation” was found.
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[Tl|search Indexed Shelves X|
& [ (][] o] [ [[=][=]
Search Reguest:
|wnrkstati|:|n
Search Reset Cloze Help
11 Books with Hit= Found:
| MNarme Title
%2 |SPIU240 0= WART.OISPF User's Guide Yal |l =
&2 |SPTLIG40 zIOS WART O ISPF User's Guide Vol |
i ISPZSC40 0T YRT .0 ISPF SCLM Project Manager's and Developer's Guide [ |
&2 ISPZPC40 05 VMR .0 ISPF Planning and Customizing
% |SPISG40 7I0S YR 0 ISPF Services Guide -

18 Search Results For Book [SPZPC40

2.1 417 ISPSPROF Workstation Download Defaults

2.1.4.16 ISPSPROF Warkstation Defauts

2.1.3.1 CresteModify Settings and Regenerate Weywword File
A 5 Workstation File Rame Engueus

2.1.4.15 1SPSPROF General Walues

E.1 D and POF Services in CLIST Commands

E.10 OM and PDF Services in TSOREXK Commands
FROMT_1.5 ISPF Client/Zerver component changes

B .2 DM and POF Services in COBOL Programs

BE.4 DM and POF Services in FORTRAR Programs

-

If the shelf being searched is an extended shelf, the results of the search (PDFs)

are listed in the first of the lower two panes of the Search Indexed Shelves
window, and the second lower pane is empty.

listed for the selected book, and:
* The Book Reader program will open (see below)
* The book with the search results will be displayed

If the results are for a bookshelf search, double-click any of the search results

* A Search Book window will be open on the Book Reader window showing

all of the search results for that book
+ All words matching the search are highlighted in red.
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% X\ Books"ISPZPC40.B00: z/0S ¥1R7.0 ISPF Planning and Cu
File

Edit Wiew MNavigate Search MNotes Help
M | &« & B

Font IE

& z,/05 WIRY.0 I15PF Planning and Cust

I+ +++ ++

+ 4+

COWER Book Cover
NOTICES Motices
ERDITION Edition Motice
COMTEMTS Table of Contents
& PREFACE Preface
& FRONT_1 Summary of Changes

FRONT_2 What's in the z/05 W1R7
z/05 VIR O 1SPF
& 2.0 Chapter 2. Customizing I5PF

# 1.0 Chapter 1.

# 3.0 Chapter 3. Customizing Divi

& 4.0 Chapter 4. Customizing POF

& 4.0 Appendix A, |5PF Enqueue H

A1 Serfalizing with Mon-13PF T2
#.2 |SPF Data Set Integrity Eng :

A3 Member Name Enqueue

#.4 15PF GUI TS0 Linemade e -
A5 Workstation File Mame Eng &

ALh SCLMOWSAM Engqueue

2 B.0 Appendix B. Dialog Developr :
C.0 Appendix C. Programming Int]
ISPF Data Set Da &

0.0 Appendix D.
& E.0 Appendix E. Accessibility
& BACK_1 Notices

IMDEX Index

COMMENTS Readers' Comments --

QR aE =
1

' A5 Workstadion File Name Enqueue

fallowing EMQ macro for the workstation file;

# Search Book: X:"Books' ISPZPC40.BOC

Q& i &= e I—
BininjEinNEE

Search Reguest:

|WD rkstation

| workstation

| Search || Reset || Cloze || Help |

Search Results:

i| [2-1.4.17 ISPSPROF Workstation Download Defaults

2| 2.1.4.16 ISPSPROF Workstation Defaults

2.1.3.1 CreateModify Settings and Regenerate Keyword
A5 Workstation File Name Engueue

| [2.1.4.151SPSPROF General Values

B.1 DM and PDF Services in CLIST Commands

B.10 DM and PDF Services in TSO/REXX Commands

: FRONT_1.5 ISPF Client/Server component changes

B &

158 Results.

To restrict the concurrent use of a werkstatior file through ISPFs disi

L LLappe

lanks to -

If the results are for an extended shelf search, double-click any of the PDFs
listed (note that the first PDF in the list is automatically selected) and:

a. For Windows:

* The Adobe Reader application is launched for the PDF

¢ If the IBM Advanced Linguistics Search (ALS) Plug-in for Adobe, V1.3 or
higher, is installed, the Plug-in will be launched, and if the PDF is

enabled with an ALS index, a ranked list of topic hits in the PDF is

displayed. Selecting any of the topic hits (note that the first topic in the
list is automatically selected) displays that topic with hits highlighted,

within Adobe Reader.
b. For Linux:

¢ The PDF reader application that has been configured to Softcopy Reader,

if any, is launched.

Searching a shelf using the regular search function—selected
documents

You can select multiple documents in a shelf to search.
1.

From the List of Shelves, select a shelf to search. The documents in the selected
shelf will be listed in the lower window.

From the list of documents, select the ones you want to search by highlighting

(clicking on) them. Use your keyboard keys to help select books

- hold down

the Shift key to select a list of documents or hold down the Ctrl key to select

specific documents.
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The following example shows four books selected from shelf ISPZPM40. If the
shelf has an associated search index file, all books contained in the search index
will have a book icon that has a sheet of paper behind the book.

Note: Note that if the selected shelf is an XKS (extended shelf), PDFs are likely
listed and may be selected to be searched. In this case, the corresponding
BookManager Books (if any) for the selected PDF will actually be
searched.

E]IBM Softcopy Reader: Shelf Organizer

File Edit Miew Search Active Directoriezs  Help

=131 x|

ﬂ|@|%|@ &| ﬁ Font |Tahuma * | Font Size |M
————

List of Shelves
l Narne I Diste I Ttle |
Iﬂ IFCSBEODS 028/11/05 17.57:58 [EREF %3R5 Bookshelf -
EH ISF4BRESO 02/11/05 16:58:23 /0S5 Y1R7.0 SDSF Bookshelf |
ﬂl ISF4BRESO 02/11,/05 16:58:28 [2/0S Y1R7.0 SDSF POF Extended Shelf
;‘EIISPZF’M-’-?D 02/11,/05 17:08:42 2f0S Y1R7.0 ISPF BockShelf
ml ISPZFPM40 02/11,/05 17:.09:03 /0S5 Y1R7.0 ISPF POF Extended Shelf
m I J4BkKA0 02/11/05 17:00:20 zf0S5 Y1R7.0 TSO/E Bookshelf :
ﬂl BOTZBkKAD 08,/11/05 17:41:32 |2/05 Y1R7.0 BDT PDF Extended Shelf |

Shelf ISPZPMA0 205 RT.0ISPF BookShelf

| &||[D]] 5| 8¢

J| Title: || Drate || Documet || Marme

@ 205 Y1R7.0 ISPF Dialog Developer',,, 07/12/05 21:23:39 SC34-4821-04 [SPZDG40
@ /05 Y1R7.0 ISPF DTL Guide 071205 21:24:19 |SC34-4824-04 [[SPZDT40
@ 205 %1R7.0 ISPF Edit and Edit Mac,., 071205 21:33:35 SC34-42820-04 ISPZEM40
E» z/05 W1R7.0 ISPF Messages and Co,.. [07f12/05 22:58:58 |SC34-4815-04 ISPZRMC40
@ 205 W1R7.0 ISPF Planning and Cus,., [07,/13,/05 00:36:49 |GC34-4814-04 ISPZPC40
@ z/05 Y 1R7.0 ISPF Reference Surmm... 07/11,05 21:07:10 SC34-42816-04 [SPZRS40
@ 205 Y 1R7.0 ISPF SCLM Project Ma... 0771105 21:09:36 |SC34-42317-04 [ISPZSC40
@ z/05 Y 1R7.0 ISPF Services Guide 07/13,05 03:03:39 SC34-4819-04 [SPZSG40
E» z/05 Y1R7.0 ISPF SCLM Reference 07712/05 03:42:31 |SC34-428158-04 ISPZSR40
@ 205 Y1R7.0 ISPF User's Guide Yol I 07/12,/05 20:38:02 (SC34-4223-04 [ISPZU240

3. From the Menu Bar: Click Search, then click Selected Books.

You can also click the Search icon EL in the lower pane

The Search Selected Book(s) window (following) will open with:

e The number of books found with search matches

* A list of the books containing matches (the first book in the list will be

highlighted)

A list of the specific search results for the highlighted book
You can highlight any of the books in the list and see the search results.
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x|
Q| HE BE &

Search Reguest:

|vvnrkstaﬁun

Search Reset Close Help

4 Books with Hit= Fourd:

Mame Title
& [SPZDG40 DS WM RET D ISPF Dialog Developer's Guide
&2 ISPZEM40 0= Y RT .0 IZPF Edit and Edit Macros
&2 [SPIRS40 Zi2Z VRT 0 ISPF Reference Summaty
£ ISPZSG40 ZIOS WM RT 0 ISPF Services Guide

23 Search Resultz For Book ISPZDG40

2311 Parameters

5.1 Howw to Display an LApplication in GUI Mode

5.2 Cther Considerations

2133 13PF Graphical User Interface in Batch Made 2
E.5 General —
FROMT_1.5 Using Lookat to ook up message explanations
7.1 .14 Defining the Panel Section

6.4.1 Defining Menus

71151 GU Mode

4.5 Movable Pop-Ups

l

4. Double-click any of the search results listed for the selected book, and:
* The Book Reader program will open
* The book with the search results will be displayed

¢ A Search Book window will be open on the Book Reader window showing
all of the search results for that book

* All words matching the search are highlighted in red.

Customizing the search (regular search only)

Using the toolbar functions you can customize the way the books on the shelf
(shelves) are searched and how the search results are listed. (Note: There are
default settings if you don’t select any of the customization functions.)

Using the Search toolbar functions

(ﬂl Search Bookshelves

Qo wd EE &

Specify the searching method
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One of the following searching methods must be specified:

o
Exact Case-sensitive

Finds only words matching the search request exactly, including case.

J;
Exact Non Case-sensitive

Finds words exactly matching the search request, but ignoring upper/lower case.

r
EL’ Fuzzy (Default)

Uses a morphological fuzzy search algorithm to identify appropriate matches.
Specify how you want the results listed

One of the following two options must be selected:

When a search is performed, the search results are listed in the sequence as they
appear in the book.

(2]

List Results in Sequence

List Results in Order of Importance (Default)

When a search is performed, the search results are listed in the order of importance
(results by relevance), with the most relevant topics listed first.

Specify Where to Search

Any combination (or all) of the following three options may be chosen to specify
where to search:

|—Li- Search in topic titles (Default).

=)

Search in topic text (Default).

a Search indexed words, that is, entries in the Index topic (Default).

Using Boolean operators
The Boolean operator buttons may be displayed or hidden with the Advanced
search button:
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Click the Advanced search button to bring up the row of Boolean operators
(below) that you can use in your search.

(ﬂl Search Bookshelves W

Qo ®iE EE & EEEFEDBH

earch Reguest:

Boolean operators

Following is a list of the Boolean operators and symbols that may be included in
the search criteria. You can enter them either directly from the keyboard, or insert
them into your search by clicking on the buttons (above).

&  logical AND
I logical OR
! logical NOT

quoted phrase

Takes the character between the two single-quotes as a literal. Used only
around Boolean operators and symbols otherwise having meaning to a search
request.

[1 parenthesized expression
Controls the order of precedence of Boolean operations.
, list separator
Word or phrase separator
= equal sign
? wildcard character

* Single-character wildcard - Matches any character in the specified position.
* Multiple-character wildcard - Matches any number of any character.
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Chapter 4. Using Book Reader

This chapter shows:

e An overview of the Book Reader window, menu and toolbar
* How to start Book Reader and open an on-line book

* Specifying paths to books, PDFs, shelves and shelf indexes
* Opening a book in Book Reader

* Navigating in a book

* Viewing pictures in a book

* Searching for information in a book

* Creating and viewing notes in a book

* Using a bookmark in a book

* Printing

* Copying

* Saving a topic as an HTML file

Overview—Book Reader window, menu and toolbar

This section shows you what the Book Reader window looks like and the functions
of the menu and toolbar.

The Book Reader window
shows the four main sections of the Book Reader window:

%2 I:\Softcopy Reader User's Guide\Stuart\hlcrug17.boo: IBM Softcopy Reader User's Guide - IBM Softcopy Reader E]@
File Edit Miew Mavigate Search Ngtes Help =

Menu bar
D@ IE @ B @ @ Font W ToC Size‘IE Topic Size [ 14~ |

Bi. Softcopy Reader User's Guide : 2.0 Chapter 2. Installing IBM Softcopy Reader T Fontand fontsize T
Toolbar selection fields

COWER Book Cover
MOTICES Natices

EDITION Edition Notice i The IBM Softcapy Reader can be installed on a workstation svith FTCrasaFe] TR Windaws 2000, Windows XP or Red
CONTEMTS Table of Contents A Hat Linus(Thy) .
FRONT_1 Summary of Changes t

@ 1.0 Chapter 1. Overview “rhen you install Softcopy Reader, these items are installed on your workstation:

1.1Book Reader
1.2 Shelf Organizer

1.3 %hen to Use Each Program # Readme file - contains the latest information on the product and installation instructions

& 2.0 Chapter 2. Installing IBM Softcog ©

# 3.0 Chapter 2. Using Shelf Organizer - # User's Guide - explains how to use the Softcopy Reader

& 4.0 Chapter 4. Using Book Reader i

# 5.0 Chapter 5. Uninstalling IBM Soft 3 # Book Reader program - allows you to view and search online books and PDFs

& BACK_1 Notices g

INDEX Index g # Shelf Organizer program - allows you to view and manage online shelves, and view or search the online
boaoks or PDFs they contain.

Table of
Contents

On Windows, these options can be selected through the Windows menu Start > Programs > IBM Softcopy Reader.

2.1 software and hardware requirements

2.2 Recommended installation steps

.3 Zpecifying paths to hooks, PDFs, shelves and shelf indexes TDpICS (pages)
2.4 Installing IBM Zoftcopy Reader on Windows platforms in this book
2.5 Installing IBM Softcopy Reader on Red Hat Linux platforms

(B I+

Figure 5. Sections of the Book Reader window

Menu Contains menus of all the functions of Book Reader.
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Menu

Toolbar
Contains icons that provide shortcuts to common functions.

Also contains fields that let you select the fonts used in the Book Reader

window:
Font Select a font style that best suits your viewing needs.
TOC Size Select the font size that is used to display the table of

contents.

Topic Size Select the font size that is used to display text in the topic
window.

Click the drop-down boxes to select from the list of available fonts and
sizes.

Table of Contents
Shows the chapters of the book.

Topics of the book
Shows the currently-selected topic.

You can navigate in the Book Reader program by clicking on the menu items on
the Menu. In addition to the functions that appear on the toolbar, there are several
additional features that are available through the menus.

Following is a list of the menu items with the corresponding drop-down menu.
There is a description of each action item in the drop-down menu.

File menu
Open Opens a new book in the reader.

Book Description
Displays additional book information.

Save Topic as HTML
Allows you to save a topic as an HTML file.

Print Opens a Print window allowing you to select the printing of the current or
selected topics.

Close Closes the Book Reader.

Edit menu
Copy Copies text highlighted in the Book Reader window to the clipboard.

Place Bookmark
Places a bookmark on the current topic. The bookmarked topic will have
an icon under its heading. Using the Navigate > Go to Bookmark menu
selection will bring the reader back to this topic from other places in the
book.

Remove Bookmark
Removes the previously placed bookmark.

Select All
Selects all topics in the Table of Contents.

Deselect All
Removes all selected topics in the Table of Contents.
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User Defined Directories
Displays the User Defined Directories for Books, Bookshelves and
Bookshelf Indexes window to allow changes to the user defined Books,
Bookshelf and Bookshelf Index paths.

View menu

Expand All
Expands all topics and subtopics to display the entire topic tree in the
Table of Contents panel.

Collapse All
Collapses all topics and subtopics to display only the top-level topics in the
Table of Contents panel.

Pictures > Show Pictures in Text
Determines whether pictures are displayed inline with the text. If this
check box is not selected, pictures can be opened manually by clicking on
the picture labels. When opened manually, the pictures will be displayed in
a separate window.

Definition lists > Compact if possible

* When this check box is selected, the definition term and description will
be displayed (if possible) on the same line.

* When this check box is cleared, the definition term and description will
be displayed on separate lines.

Build > Older version
Controls possible "reflow” problems which may exist in displayed content.
If text does not wrap properly across lines, select this check box and
redisplay content.

Navigate menu

By Topics
Opens the Table of Contents window. Double-click a topic to open it in the
Book Reader window.

By Topics Seen
Opens the Topics Seen window. Double-click a topic to open it in the Book
Reader window.

By Revisions
If a book contains revisions the By Revisions text bar will be active. Click
on this bar and the Revisions window will open with the list of revised
topics. Double-click a topic to open it in the Book Reader window.

By Figures
Opens the Figures window. Double-click a figure in the list to open the
topic in which it appears.

By Tables
Opens the Tables window. Double-click a table in the list to open the topic
in which it appears.

By Index
Opens the Index window and displays the book’s index. Click the
underlined topic numbers in the Index to go to the appropriate topic.

Go To Topic ID
Opens the Go To Topic ID window. Enter the desired topic ID (e.g. “2.0” or
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“GLOSSARY”) in the Enter a Topic ID panel. The selected topic (if the ID
is valid) will be opened in the Book Reader window.

Go To Bookmark
Returns to the topic previously bookmarked during the current session.

Go To Previous Topic
Moves to the previous sequential topic in the book.

Go To Next Topic
Moves to the next sequential topic in the book.

Search menu

Search Book
Opens the Search Book window.

Display Search Results
Displays a list of search results from the last search performed.
Double-click on a search result to see the topic containing the result.

Go To Previous Topic Match
Moves to the topic for the previous sequential result from the last search.

Go to Next Topic Match
Moves to the topic for the next sequential result from the last search.

Notes menu

New Displays the New Note input window that allows you to create a new note
attached to the currently displayed topic.

Display Notes List
Displays the Notes List window showing all notes in this book.
Double-click on the notes in the list to see the topic containing the note.

Help menu

Getting Started
Displays the help screen.

User’s Guide
Opens the IBM Softcopy Reader User’s Guide

About Softcopy Reader
Opens the About Softcopy Reader window, which lists the current version,
service level, and driver level.

Toolbar

You can navigate in the Book Reader program by clicking on the icons on the
toolbar.

i = @B QERE HE 2] |2

LEI Navigate by Table of Contents

Clicking on this icon expands the current topic (text and pictures) to the full size of
the Book Reader window. The Table of Contents will open in a smaller floating
window that you can position anywhere. Double-click a topic to open it in the
main window. Also available from the menu: Navigate > By Table of Contents.

IBM Softcopy Reader User’s Guide



LE-| Navigate by Revisions

If a book contains revisions this icon will be active. Click on the icon and a
window will open with the list of revised topics. Double-click a topic to open it in
the main window. Also available from the menu: Navigate > By Revisions.

LEI Navigate by Topics Seen

Displays the history of topics visited. Double-click on a topic to open it in the main
window.

Also available from the menu: Navigate > By Topics Seen.

A
" Back

Moves to the previous topic visited.

s
* Forward

Moves to the next topic visited (after using the Back button).

EI Go to Previous Topic
Moves to the previous sequential topic in the book.

Also available from the menu: Navigate > Go To Previous Topic.

LE; Go to Next Topic
Moves to the next sequential topic in the book.

Also available from the menu: Navigate > Go To Next Topic.

Ek Search

Opens the Search Book window.

Also available from the menu: Search > Search Book.

3 Display Search Results

Displays a list of search results from the last search performed. Double-click on a
search result to see the topic containing the result.

Also available from the menu: Search > Display Search Results.

E Go To Previous Topic Match

Moves to the topic for the previous sequential result from the last search.
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Also available from the menu: Search > Go To Previous Topic Match.

E Go To Next Topic Match
Moves to the topic for the next sequential result from the last search.

Also available from the menu: Search > Go To Next Topic Match.

]
i Create New Note

Displays the New Note input window that allows you to create a new note
attached to the currently displayed topic.

Also available from the menu: Notes > New.

'ﬂ Display Notes List

Displays the Notes List window showing all notes in this book. Double-click on
the notes in the list to see the topic containing the note.

Also available from the menu: Notes > Display Notes List.
= Print

Opens a Print window allowing you to select the printing of the current or selected
topics.

Also available from the menu: File > Print.

=

H Help
Displays this help screen.

Also available from the menu: Help > Getting Started.

Starting Book Reader

This topic explains how to start the Book Reader from the Windows desktop|or
[Windows command line| or from the [Linux command line}

Note: If Book Reader does not seem to start correctly, refer to[“Problems starting]
[Shelf Organizer or Book Reader” on page 8)

Starting Book Reader from the Windows desktop
1. Insert the IBM Online Library CD-ROM into the CD-ROM drive.

Note: If you are using multiple CD-ROM drives, be sure you put all of the

Online Library CD-ROMs you plan to use in the drives before starting
Book Reader or Shelf Organizer to open the Online Library.
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6.

On the Windows Desktop, start the Book Reader either by double clicking the
Book Reader desktop icon, or by clicking the Start button, and do the
following.

* Select the Programs option
* Select IBM Softcopy Reader

* In the Softcopy Reader group, select the icon for Book Reader. The IBM Book
Reader window opens.

From the menu: Click File > Open.
The Open Book window opens.

On the Open Book window, in the Look in window click the down arrow
symbol. You should see a list of drives that are physically on or attached to
your system via a network.

Click the drive letter (C:, D, etc.), then click the folder containing the book you
want to open. The books contained in the folder should be listed.

Highlight the book you want to open and then click Open.

Starting Book Reader from a command line in Windows
To start Book Reader from the command line:
1.

Open a Command Prompt and navigate to the directory where Book Reader is
installed. (Generally C:\Program Files\IBM\SCR\sys)

At the command prompt, type: hicb -d <sourcepath>
In the above example <sourcepath>= “C:\Program Files\IBM\SCR\sys”.

Advanced Book Reader features are also available from the command line
according to the following usage when typed at the command prompt:

Usage: hlcb filename -d <sourcepath> options

Where:

A11 flags must be surrounded by at least one blank character

filename Optional book name

sourcepath Required field, path hlcb is being executed from

Where options include:

-t topic Open book to a topic
-r reference Open book to a reference
-s s_options arguments Open book to a search

-h topic -s s_options arguments Open book to a topic and search

Where s _options are 0 (off) or 1 (on) for the following:

OOoONOOTL P WN =

Exact matches only

Exact matches ignoring case

Fuzzy search

List results in sequence

List results in order of importance
Search in topic text

Search in titles

Search indexed words

show advanced search options

Note: When specifying s_options:
* Positions 1-3: one and only one of the positions may be "1"
* Positions 4-5: one and only one of the positions may be "1"

* Positions 6-8: one or more of the positions may be "1”

Following are some examples of using advanced Book Reader features from the
command line when typed at a command prompt:

Chapter 4. Using Book Reader 59



hlcb "c:\books\book.boo" -d "c:\Program Files\IBM\SCR\sys" -t "1.1"
hlcb "c:\books\book.boo" -d "c:\Program Files\IBM\SCR\sys" -s "001011000" "Table 7-1"

Starting Book Reader from a command line in Linux
To start Book Reader from the command line:

1. Open a Terminal Window and navigate to the directory where Book Reader is
installed.

2. At the command prompt, type: hlcb.sh

3. Advanced Book Reader features are also available from the command line
according to the following usage when typed at the command prompt:

hlcb.sh -help
Usage: hlcb.sh filename options

Where:

A11 flags must be surrounded by at Teast one blank character

filename Optional book name

sourcepath Optional. Path hlcb.sh is being executed from

Where options include:

-t topic Open book to a topic
-r reference Open book to a reference
-s s_options arguments Open book to a search

-h topic -s s_options arguments Open book to a topic and search

Where s_options are O (off) or 1 (on) for the following:
: Exact matches only

Exact matches ignoring case

Fuzzy search

List results in sequence

List results in order of importance

Search in topic text

Search in titles

Search indexed words

show advanced search options

OOoONOOUT S~ WN —

Note: When specifying s_options:
* Positions 1-3: one and only one of the positions may be "1”
* Positions 4-5: one and only one of the positions may be "1”
* Positions 6-8: one or more of the positions may be "1"

Following are some examples of using advanced Book Reader features from the
command line when typed at a command prompt:

hlcb.sh "/home/auser/books/book.boo" -t "1.1"
hlcb.sh "/home/auser/books/book.boo" -s "001011000" "Table 7-1"

Note: The samples above assume hlcb.sh is in the current directory. If it is not, add
the directory to the path before starting.

Specifying paths to books, PDFs, shelves and shelf indexes

This section describes how to set up path names to books, PDFs, shelves and shelf
indexes so they are readily available each time you use Book Reader and Shelf
organizer.

There are two ways to access softcopy books, shelves and shelf indexes with Book
Reader and Shelf Organizer:
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Manually
Each time you want to open a book or shelf, you can manually search
through the directories and folders on your system.

Automatically
You can identify the location (set up paths) to the books, bookshelves and
bookshelf indexes that you want to work with in the User Defined
Directories for Publications, Shelves and Shelf Indexes window. The
publications, shelves and shelf indexes will then be readily available each
time you open Book Reader and Shelf Organizer.

Specifying paths
You can specify publications, shelves and shelf indexes on:
* Folders on your system’s hard disk drives
* CD-ROM drives on your system

* External hard disk drives or CD-ROM drives that you can access through a
network (you may have multiple CD-ROM drives you want to access)

¢ Other storage devices that can be attached to your system

You can do the following procedure from either Book Reader or Shelf Organizer.
1. From the menu of either Book Reader or Shelf Organizer, click Edit > User
Defined Directories.

The User Defined Directories for Publications, Shelves and Shelf Indexes
window (below) will open.

= 1

% User Defined Directories for Publications, Shelves, and Shelf Indexes

3 1

Faths for Public ations, Shelves and Indexesforailable Falders and Drives:

Chbooks .ﬁl}. i :
Lhbooks =,'}= D
EMbooks = Ei
E’shelves + BOOKS
E:pdf
CAPragram Files\BMVS CRsys < ILRDOS
EASHELWES ¢ ILROS2
=F ILRWIN
= MPT
4 OMF
= SCRT
+ i
S STOREST
s+ TAPES
4 UPLOAD =

Rermowe Sawe | | Cancel

2. In the Available Folders and Drives window [1], click on the + icons to list the
contents of each directory on your system. Select, by clicking on them, the
books, bookshelves and folders that you want to access with the Softcopy
Reader programs.
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3. Click the Add button [2] and the path will be listed in the Paths for
Publications, PDFs, Shelves and Indexes window [3]. Continue these steps until
all books, shelves and folders are listed.

You can remove unwanted items in the Paths for Publications, Shelves and
Indexes window by highlighting the item and clicking on the Remove button.

Note: At least one directory must be specified in the User Defined Directories
for Publications, Shelves and Shelf Indexes window. If only one directory
is listed, you will not be able to remove it until you add another
directory.

Opening a book in Book Reader

This section shows you how to:
* Open a book in Book Reader
* Get a description of the book
* Close a book

For information on starting the Book Reader program, see [“Starting Book Reader”]

— Opening books contained on an IBM Online Library CD-ROM
If you plan to open a book contained on an IBM Online Library CD-ROM, be
sure to insert the IBM Online Library CD-ROM into the CD-ROM drive on
your system. If you are using multiple CD-ROM drives, be sure you put all of
the Online Library CD-ROMs you plan to use in the drives before starting
Book Reader to open the Online Library.

Opening a book
1. From the menu: Click File > Open.
The Open Book window (below) will open.
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% Open Book

-.

Look In: My Computer

Oo—
O—

=3 Local Disk (C:)
&= Local Disk (D:)
=3 NS10999 (E3)

=% Local Disk (G:)

File Hame:

Files of Type:

BookManager Books

Open

Cancel

On the Open Book window in Look in: click the “down arrow” symbol.

A drop-down window will open listing all the drives that are attached to your
system either directly or via a network.
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% Open Book

ﬂ

Look In: My Computer | |5 3 |&&| o=
= My Computer =
- t““a: 3% Floppy (A2 [
““an = Local Disk (C:) o
g NS10% = Shared Documents
Locall = | gcal Disk (D)
=3 NS10999 (E:) B
=% Local Disk (G:)
File Name: |
Files of Type: | BookManager Books sl
Open Cancel

3. Click on the drive letter (C:, D:, etc.) of the drive where the book is stored, or
the drive letter of the CD-ROM drive containing the CD with the book.

The Open Book window (below) now lists all of the folders on the drive.
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% Open Book
Look In: | &% NS10999 (E:) il Oh| o
[1BOOKS [ SHELVES
CIILRDOS [ STOREST
CIRoS2 [CJ TAPES
CIILRWIN [ UPLOAD
CIMPT
] OMF
] SCRT
File Hame:

Files of Type: | BookManager Books e
Open Cancel

Click on the folder containing the book you want to open.

The Open Book window (below) now lists all of the books contained in the

selected folder.

& Open Book

w

Look In: |[] BOOKS

=/ /@) o [B8le

[y AOFIGI10.BOO

[y ABOHEVDD.BOO [ AOFIOP10.BOO [} APPHOD00.BOO [ ) AWAD3000.BOO
[} ABOINO11.BOO [ AOFIPR10.BOO [} APPP1000.BOO [} AWAG1001.B00
[} AOFCGIMO.BOO [ AOFOGI10.BOO [ ATUA2007.B00 [} AWAG2001.B00
[y AOFCOP10.BOO [ AOFOOP10.BOO [ AWADDDD1.BOO [} AWAH7000.BOO
[y AOFCPR10.B00 [ ] AOFOPR10.BOO [ ] AWAD1002.B00 [} AWAKG000.BOO
[y aPPAZ000.BOO [ ) AWADZ001.B00 [ ] AWAKI000.BO0

1 [EE

[ »

File Mame:  |AB0INO11.BO0

Files of Type: | BookManager Books

i |

Open

Cancel
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5. Highlight the book you want and then click Open.
The book opens in the Book Reader window.

% X:\Books\ab0in01l.boo: Installing, Managing, and Using the Online Library - IBM Softcopy Reader

/oS

File Edit Yiew Mavigate Search MNaotes Help

EEIGE

|@ @ @ @ Font |TrebuchetMS | Toc Size [14_~ | Topic Size [12 ~ |

& Installing, Managing, and Using the On : 1.1 Chapter 1. What Is the IBM Online Library?
COVER Book Cover

& [1.1 Chapter 1. What |s the IBMW

1.3 Chapter 3. PDF Files on IBA 8
# 2.0 Part 2, Installing Softcopy Tool 1 # The |Bi\ Bookitanager READ component of 2/05 or 057320

s

4 & 3.0 Part 3. Managing Bookiianager | .
3 # The Bk Baokii, READ | d far Wi
4+ & 4.0Part4. Using BookManager and| © ® oeanager 1eenses program far
< & APPENDIXT Part 5. Appendixes - # The Library Server component of z/05 WIRS or z/0%.e WIRS

beyond, Version 4 Release 3

;| dowin the hall; it's right under your fingertips.

D

The "IBM Online Library' contains 1B publications and product books in softcopy format, organized into collections and

NOTICES Motices [ | packazed on CD-ROMs or DVDs. Originally, the softcopy colletions cantained only books awailable in Eookianager farmat,
ECITION Edition Notice Increasingly, collections akko contain books available in other formats, such as Portable Data Format (PDF) and HTAL.
CONTENTS Table of Contents All the BookManager books in these softcopy collections can be viewed and searched electronically, without changing
¢ & CHANGES What's New ‘|them, on workstations and portable laptop PCs {running Windows), host systems (running z/05, 54390, /v, VI, or CICS),
= & 1.0Part 1. Introduction ‘land the A5/400 System. The same book can be wiewed at your waorkstation or terminal using any of the following methods:

= & 1.2 Chapter 2. Introducing the | # The IBAl Softcopy Reader, which is provided at no charge with the library on the softcopy collections

# The |BA\ BookManager BookServer component of /05 W1R4 or earlier, zf05%.& YW1R4 or earlier, ar 05/390
# The Library Server for Multi Platform licensed programs for Linus, AD, and Windows

# A5/400 InfoSeeker, which is provided as a part of the Operating System/400 in Wersion 3 and through, but not

‘| Think of the IBM Online Library as you would think of the public library in your community. & public ibrary houses large

‘[ numbers of books organized into 3 variety of collsctions by subject. Each collection accupies one or mors booksheles,

| The bookshelves contain the books. The public library has a Kbrarian and tools to help you discover what is available, and
:|find what you want, The IBA\ Online Library, like your community library, also contains large numbers of publications and
| product books organized into collections. But, the I Online Library iz not 3 big building ar a large room; it's Kttle

;| packages of CO-ROMs and DVDs. It's not on long rows of shelves and stacks of books; it's online. It's not up the street or

Getting a description of a book

To see a description of the book, click File, then click Book Description.

“* Book Description

w

BookTitle
IEM Online Library: Softcopy Collection Kit Lzer's Guide

Copyright Statement
2 Copyright IBEM Corp. 1992

Security Classification
Document Humber Build Yersion
C28-1700-00 12

Date Published Date Built
OSM 4892 14:29:47

Authors

File Hame

ENBOORSVABIHEY 00 B
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Closing a book
There are two ways to close a book.

1. Open another book. The book currently open is closed and the new book
displayed in Book Reader.

2. Click File, then click Close.
This will close the book and Book Reader.

Navigating in a book

This section shows how to navigate (move around a book and go to specific topics)
within an on-line book in Book Reader.

The primary ways of navigating in a book include:
* Selecting items from the Table of Contents

* Using the navigation buttons on the toolbar

* Using the Navigate menu

Using the Table of Contents

When you open a book, the Table of Contents is displayed on the left side of the
Book Reader window. You can go directly to any topic in the Table of Contents by
double clicking on the topic.

Expanding and collapsing the topics

Unexpanded topics will have a + (plus) icon next to them. Click on the + to
expand or collapse the topic. When you expand a topic, the - (minus) icon will
appear. To expand or collapse “all” topics, choose View > Expand All or View >
Collapse All from the menu.

Moving the Table of Contents to a floating window

You can close the Table of Contents window on the left side and open it as a
floating window that you can move around and position anywhere on your screen.
When you do this, the topic window expands to fill the Book Reader window. You
can do this from:

* The menu - click: Navigate > Topics

e The Toolbar - click: LEI

Widening and narrowing the Table of Contents window and
the topic window

When Book Reader opens, the Table of Contents window is about 30% of the

1
width of the Book Reader window. By clicking the arrow keys ¥l on the bar to

the right of the Table of Contents window, you can widen the Table of Contents
window to take up all of the Book Reader window, or narrow it so that it takes up
none of the window.

* Click the bottom arrow (pointing right) to widen Table of Contents window.

* Click the top arrow (pointing left) to narrow the Table of Contents window.
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As the Table of Contents windows widens or narrows, the topic window narrows
or widens.

There are three different settings possible:

* Only the topic window displayed

* Only the Table of Contents window displayed

* Both the topic and the Table of contents window displayed

Using the toolbar

Following are ways to navigate within a book by clicking on the buttons in the
toolbar.

iR SN E EEIEENENE:

LE Go to Next Topic
Moves to the next sequential topic in the book.

Also available from the menu: Navigate > Go To Next Topic.

EI Go to Previous Topic
Moves to the previous sequential topic in the book.
Also available from the menu: Navigate > Go To Previous Topic.

i
" Back

Moves to the previous topic visited.

s
¥ Forward

Moves to the next topic visited (after using the Back button).

LEI Navigate by Topics Seen

Displays the history of topics visited. Double-click a topic to open it in the main
window.

Also available from the menu: Navigate > By Topics Seen.

LF-' Navigate by Revisions
If a book contains revisions this icon will be active. Click on the icon and a
window will open with the list of revised topics. Double-click a topic to open it in

the main window.

Also available from the menu: Navigate > By Revisions.
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Navigating using menu functions

Following are ways to navigate within a book by clicking on the functions listed in
the Navigate menu.

By Topics Opens the Table of Contents window.
Double-click a topic to open it in the Book Reader window.

By Topics Seen
Opens the Topics Seen window.

Double-click a topic to open it in the Book Reader window.
By Revisions If a book contains revisions the By Revisions text bar will be active.

Click on this bar and the Revisions window will open with the list
of revised topics. Double-click a topic to open it in the Book
Reader window.

By Figures Opens the Figures window.

Double-click on a figure in the list to display the topic in which it
appears.

By Tables Opens the Tables window.

Double-click on a table in the list to display the topic in which it
appears.

By Index Opens the Index window and displays the book’s index.
Click on the underlined topic numbers in the Index to go to the
appropriate topic.

Go To Topic ID
Opens the Go To Topic ID window.

Enter the desired topic ID (e.g. “2.0” or “GLOSSARY”) in the Enter
a Topic ID panel. The selected topic (if the ID is valid) will be
opened in the Softcopy Reader window.

Go To Bookmark
Returns to the topic previously book marked during the current
session.

Go To Previous Topic
Moves to the previous sequential topic in the book.

Go To Next Topic
Moves to the next sequential topic in the book.

Viewing pictures in a book

You can select if you want the pictures in the book to be automatically displayed
in the text. From the Book Reader menu, click View > Pictures.
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The Show Pictures in Text option determines whether pictures are displayed inline
with the text. If this check box is not selected, pictures can be opened manually by
clicking on the picture labels. When opened manually, the pictures will be
displayed in a separate window.

Searching for information in a book

70

This section describes how to:

1. Initiate a search for specific information (word or words) in a book.

Entering a new search request
Looking at previous search requests

2. Navigate between search results

3. Customize the way the book is searched and the results displayed:

Find an exact match (case sensitive)

Find an exact match (not case sensitive)

Fuzzy match

Use Boolean operators in the search

Specify what material in the book to search (titles, text, and indexed words)

List the results in order of importance (or in page sequence)

Starting the search

You can search by entering a new word, or by looking at words previously
searched.

Entering a New Search Request

You can start the search process from either the menu or the toolbar.

1. Start the search process:

From the menu: Click Search, then click Search Book.

Or, from the Toolbar: Click E:k‘ [Search]
The Search Book window will open.

2. Enter one or more search words in the Search Request window. The example
below shows “OS/390” as the search request. You can customize the search in
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several ways—see |’Customizing the search” on page 73|

#. Search Book: X:"Books \ INSTALL. hoo

Qo Sl =
Search Request: & EED 1] DEE

(057390 |

Rezet Cloze Help

Search Resuts’

Lvvaiting Search. .

Buttons on the Search Book window:

Search
Start the search process.

Reset Clears the Search Request window and returns the options to their
default state.

Close Closes the search window.

Help Displays the help screen.

3. Click Search to start the search. The Search Results window (below) lists all of
the search results found in the book, and the number of topics with matches
found at the bottom of the window.
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4. Double-click on any of the search results listed in the Search Results window
and the corresponding topic will be displayed in the Book Reader window,
with all words matching the search criteria highlighted in red.

Looking at Previous Search Requests from the Search Book Window

You can look at the search results of other words previously searched by clicking
the “down arrow” just below the Search Request window, and clicking Search. The
Search Results panel shows the topics that matched the search, including the
number of search results found. Double-click on any of the search results and the
corresponding topic will be displayed in the Book Reader window with all words
matching the search criteria highlighted in red.

Navigating between search results
You can look at the results of the last search you made.
1. From the menu: Click Search > Display Search Results.

The Search Results window (below) will open listing the search results from
your last search.
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2. You can navigate (jump from one search result topic to another) in the
following ways:

* By double clicking on specific item in the Search Results window. The topic
(page of the book) that corresponds to the search result you clicked on will
open in the Book Reader window.

¢ By clicking on Go To Previous Topic Match and Go To Next Topic Match in
the drop-down window under Search. This opens up the corresponding page
in the Book Reader window.

* By clicking the toolbar icons E [Previous] and E [Next]

Customizing the search

Using the toolbar functions you can customize the way the book is searched and
how the search results are listed.

Note: There are default settings if you don’t select any of the customization
functions.

Using the Search toolbar functions

N Lo EEE &

Specify the searching method
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One of the following must be specified:

-
EL Exact Case-sensitive

Finds only words matching the search request exactly, including case.

Q Exact Non Case-sensitive

Finds words exactly matching the search request, but ignoring upper/lower case.

r
aﬁ Fuzzy (Default)

Uses a morphological fuzzy search algorithm to identify appropriate matches.
Specify how you want the results listed

One of the following two options must be selected:

|
_ltl List Results in Sequence

When a search is performed, the search results are listed in the sequence as they
appear in the book.

g List Results in Order of Importance (Default)

When a search is performed, the search results are listed in the order of importance
(results by relevance), with the most relevant topics listed first.

Specify Where to Search

Any combination (or all) of the following three options may be chosen to specify
where to search:

E’n Search in topic titles (Default).
|ﬂ Search in topic text (Default).

E!z. Search indexed words (that is, entries in the Index topic) (Default)

Using Boolean operators: The Boolean operator buttons may be displayed or
hidden with the Advanced search button:

Click the Advanced search button to bring up the row of Boolean operators
(below) that you can use in your search.

IBM Softcopy Reader User’s Guide



Search Book : ]|

QX @o EEE
Search Reguest: EDED@DEE Boolean operators

Following is a list of the Boolean operators and symbols that may be included in
the search criteria. You can enter them either directly from the keyboard, or insert
them into your search by clicking on the buttons (above).

&  logical AND
I logical OR
! logical NOT

144

quoted phrase

Takes the character between the two single-quotes as a literal. Used only
around Boolean operators and symbols otherwise having meaning to a search
request.

[1  parenthesized expression
Controls the order of precedence of Boolean operations.
, list separator
Word or phrase separator
= equal sign
? wildcard character

* Single-character wildcard - Matches any character in the specified position.
¢ Multiple-character wildcard - Matches any number of any character.

Creating and viewing notes in a book

This section describes how:
¢ Create a new note in a book

* How to display the list of notes in a book, and view them

Creating a note
You can create and view notes from either the menu or the toolbar.
1. Open the new Notes window

From the menu: Click Notes > New.

C ]
Or, from the toolbar: Click [New Note]

2. In the Notes window (below), you will see the topic you selected to put a note
under, and an open window where you can type your note. The example
shows that a note will be attached to the heading page for Part 2 of the book.
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Notes x|

2.0 Part 2. Installing Softcopy Tools

Type your nate in this area.

Cancel Sdve

3. Click Save to save the note or click Cancel to cancel the note - close the
window and exit the Note function.

Viewing notes

1. Open the Notes list window
From the menu: Click Notes > Display Notes List.

Or, from the Toolbar: Click 'ﬂ [Notes List]
2. The Notes window lists all of the notes in the book.

potes x
EIEA= |2 2

Taopic ID First Hote Line
2.0 Type your note in this area.
3.0 Follow up OS5 requirements.

I:E

Hote Body
Faollow up 08 reguirements.

hatwersions of Windows are supparted?

The upper window lists the topic ID and first line of each note in the book.
Double-click any of the notes to see the full text for the note in the Note Body
window. The Book Reader will now be positioned at the topic in which the
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note appears. The body of a note may be edited in the Note Body window, but
you must save the changes (to avoid losing them) before another note is
displayed.

Description of the Notes window toolbar

R Edled 2

b |
i Create New Note

Opens an input window to enter a new note on the currently displayed topic.

'Pr' Delete Note

Deletes the currently-selected note.

E Save Note

Saves any changes made to the currently displayed note.

[4= |
ol Previous Note

Moves to the previous note in the list and displays the note text under the Note
Body section. The Book Reader will not be positioned to the note topic.

EI Next Note

Moves to the next note in the list and displays the note text under the Note Body
section. The Book Reader will not be positioned to the note topic.

H Help

Displays this help screen.

Using a bookmark in a book

This section describes:

* Placing the bookmark

* Finding (going to) the book marked page
* Removing the bookmark

Placing the bookmark

You can place the bookmark on any topic (page) in a book. You can have only one
bookmark in a book. If you try to place a second bookmark, the first one will be
removed.

1. Select a topic (page in the book you want to bookmark
2. Click Edit, then click Place Bookmark

Chapter 4. Using Book Reader 77



The bookmark icon will be placed at the top of your selected topic (page). In
the example below, you can see the bookmark next to the chapter title.
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Finding (going to) the bookmarked page

You can go to a bookmarked page from other places in the book.

On the menu click Navigate > Go to Bookmark.

Removing the bookmark

On the menu, click Edit > Remove Bookmark.

Printing topics
This section describes:
* Printing the current topic
* Printing selected topics
* Printing a range of topics

Printing the current topic

This allows you to print the topic currently displayed in the Book Reader window.
Only the topic currently displayed will be printed, even if you have other topics
highlighted in the Table of Contents.

1. Start the print process:

You can start the print process from either the menu or the toolbar

From the menu: Click File > Print.

Or, from the toolbar: Click = [Print]
The Print window (below) will open.
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Print

Print which topics?

current Selected Cancel

2. Click Current.
* The topic currently displayed on your screen will be printed.

¢ The Print window on your PC will open allowing you to specify how and
where you want to print the current topic.

Printing selected topics

1. Select the topics you want to print from the Table of Contents by highlighting
(clicking on) them. Use your keyboard keys to help select topics - hold down
the Shift key to select a list of topics or hold down the Ctrl key to select specific
topics.

2. Start the print process:

You can start the print process from either the menu or the toolbar

From the menu: Click File > Print.

Or, from the Toolbar: Click = [Print]
The Print window will open.
3. Click Selected.

* All of the topics you selected for printing will be displayed in the Book
Reader window. They will be in sequential order, from the lowest numbered
topic to the highest, regardless of how you selected them.

* The Print window on your PC will open allowing you to specify how and
where you want to print the selected topics.

Printing a range of topics

1. Select the topics you want to print from the Table of Contents by highlighting
(clicking on) them. Use your keyboard keys to help select topics - hold down
the Ctrl key and select the first Table of Contents topic in the range by clicking
on it, then select the last topic in the range by clicking on it.

2. Start the print process:
You can start the print process from either the menu or the toolbar
From the menu: Click File > Print.

Or, from the Toolbar: Click = [Print]

The Print window (below) will open.

Chapter 4. Using Book Reader 79



current Selected Cancel

3. Click Range.

* The range of topics you selected for printing will be displayed in the Book
Reader window. They will be in sequential order, from the lowest numbered
topic to the highest, regardless of how you selected them.

¢ The Print window on your PC will open allowing you to specify how and
where you want to print the specified range of topics.

Copying
This section describes how to copy text from a book topic to the Windows

clipboard. Once in the clipboard, you can copy the text to a text- or
word-processing program.

Copying text to the clipboard
1. Highlight the text you want to copy.

& @ ant|TrebuchelMS ¥ | TOC Size |14 ¥ | Topic Size |14

1.7 Chapter 1. What Is the IBM Online Library?

The "IBM Online Library" contains IBM publications and product books in softcopy format, organized
into collections and packaged on CO-ROMs or DWDs. Originally, the softcopy collections contained
only books available in BookManager format. Increasingly, collections also contain books available in
other farffiats, such as Portable Data Format (FDF) and HTML.

All the BookManager books in these softcopy collections can be viewed and searched electraonically,
without changing them, on workstations and portable laptop PCs [running Windows), host systems

[running z/05, 05,390, /M, WM, or CICS], and the AS/400 System. The same book can be wiewed

at your waorkstation or terminal using amy of the following methods:

# The IBM Softcopy Reader, which is provided at no charge with the library on the softcopy
collections

# The IBM BookManager READ component of /0% or 05/3%90

2. Click Edit, then click Copy.
Note: On some systems, when you click Edit the highlighting on the material

you selected will disappear. The material will still copy to the clipboard
when you click Copy.
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Saving a topic as an HTML file

This section describes how to save a topic as an HTML file.

Saving a topic

This allows you to save the current topic as an HTML file. All of the text will be
converted to HTML. Any hypertext links in the softcopy book will not be

converted to links in the HTML file that you create.

1. Open the softcopy book to the topic you wish to save as an HTML file.

2. From the Book Reader menu: Click File > Save Topic as HTML.

The Save Topic HTML window opens. A file name will be assigned to the file

with the extension.htm.

& Save Topic HTML

Save In: |[] BOOKS

1 Desktop
1 My Documents
My Computer
34 Floppy (A:)
= Local Disk (C:)
= Shared Documents
= Local Disk (D:)
= NS10999 (E3)

~| =g o

4|

File Name: |1E_E_EIOOK5_AEIEIINEI11.EIOD.htm

Files of Type: | HTML Files

3 |

Save

Cancel

3. You can rename the filename and select any directory (with write permission)

on your system to save the file.
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Chapter 5. Uninstalling IBM Softcopy Reader

You can easily uninstall (remove) IBM Softcopy Reader (Book Reader and Shelf
Organizer) from your system.

Note: If you have created any shelf (*.BKS or *.XKS) or notes (*.NTF) files in the
directory where the Softcopy Reader is installed (or its subdirectories) you
should backup up those files to a different location before uninstalling.

From a Windows workstation

To remove IBM Softcopy Reader from your Windows workstation:
1. Double-click My Computer on your Windows Desktop.
The My Computer window opens.
2. Double-click Control Panel.
The Control Panel window opens.
3. Double-click Add or Remove Programs.
The Add or Remove Programs window opens.
4. Scroll down the list of software and select IBM Softcopy Reader.

5. Click Change/Remove and follow the instructions on the screen.

From a Linux workstation

To uninstall IBM Softcopy Reader program from your Linux workstation:
1. Change to root user, if necessary.

2. Remove the program files from the installation directory that was specified in
[“Installing IBM Softcopy Reader on Red Hat Linux platforms” on page 9.

3. Remove program directory from user paths.
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Notices

This information was developed for products and services offered in the USA.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
USA

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

Mail Station P300

2455 South Road
Poughkeepsie, NY 12601-5400
USA

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

The following terms are registered trademarks of International Business Machines
Corporation in the United States, other countries, or both:

BookManager
IBM

Adobe and Adobe Reader are trademarks of Adobe Systems Incorporated in the
United States, other countries, or both.

InstallShield is a registered trademark and service mark of InstallShield Software
Corporation in the United States and/or other countries.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

Red Hat is a registered trademark of Red Hat, Inc. in the United States and other
countries.

Other company, product, and service names may be trademarks or service marks
of others.
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starting the search 70
shelf indexes
specifying paths to 6
shelf list
displayed in Shelf Organizer 13
filtering 17
rebuilding with Auto Refresh 25
Shelf Organizer
closing 30
functions 3
overview 1
running 11
starting 28, 31
starting from command line 19
window
described 13

shelves
See also extended shelves
closing 30

creating 30
getting a description 29
opening 27
saving before uninstall 83
searching 40
searching an indexed shelf 44
selecting 29
specifying paths to 6
Softcopy Reader
components 1
installing 5
on Red Hat Linux 9
on Windows 7
installing on Linux
from Bookmanager web site 10
from CD-ROM 9
installing on Windows
from Bookmanager web site 8
from CD-ROM 7
uninstalling 83
from Linux 83
from Windows 83

T

table of contents
collapsing 67
expanding 67
moving to a floating window 67
navigating a book using 67
Table of Contents window
narrowing 67
opening 69
widening 67
Tables window
opening 69
text
copying to clipboard 80
TOC Size selector 54
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toolbars
See also Book Reader toolbar
See List of Shelves toolbar
Topic Size selector 54
topic window
narrowing 67
widening 67
topics
collapsing 67
expanding 67
go to next 68
go to next topic visited 68
go to previous 68
go to previous topic visited 68
list of revised topics 68
list of topics visited 68
printing
arange 79
selected topics 79
the current topic 78
saving to HTML file 81
Topics Seen window
opening 69

U

user defined directories
described 22

w

wildcard
in a filter regular expression 17
Windows
installing Softcopy Reader 7
uninstalling Softcopy Reader 83

V4

zoom
See font selector fields
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